在Vim中隐藏制表符

我刚刚开始学习Go,并且在运行 go fmt </ code>后,我发现 标签 ^ I </ code>字符出现在我的代码中:</ p>

 包main 
import“ fmt”

func main(){
^ Ifmt。 Println(“ H​​ello world!”)
}
</ code> </ pre>

有没有一种方法可以将Vim配置为不显示这些字符,同时仍保留文件中的选项卡 本身?</ p>
</ div>

展开原文

原文

I've just begun learning Go, and upon running go fmt, I am finding tab ^I characters appear in my code:

package main
import "fmt"

func main() {
  ^Ifmt.Println("Hello world!")
}

Is there a way I can configure Vim to not display these characters, while still preserving the tabs in the file itself?

vim
douqiao1997
douqiao1997 检查:详细设置列表?检查是否设置了列表选项,以及在何处。:helplist,:helplistchars。
接近 4 年之前 回复

2个回答



按照Amadan的建议,我编辑了:verbose set list?</ code>返回的文件,对我来说,这是< 代码>〜/的.vim / INIT / options.vim </代码>。 删除 set list </ code>可以为我解决问题</ p>
</ div>

展开原文

原文

Following Amadan's suggestion, I edited the file that :verbose set list? returned, which for me is ~/.vim/init/options.vim. Removing set list solved the problem for me

dsyo9700
dsyo9700 我正在使用机器上的自定义Vim配置
接近 4 年之前 回复
duanbing6955
duanbing6955 如果您不知道它的作用并且不想要它的作用,为什么还要把它放在那里?
接近 4 年之前 回复



只需在您的配置文件中删除此行:
:set listchars = tab:\(无论如何)\ </ 代码> </ p>

<代码>设置列表</代码>在以后的字符编辑中可能会很有用。 我不建议只删除它而不知道您在做什么。</ p>
</ div>

展开原文

原文

Just remove this line in your configuration file: :set listchars=tab:\(whatever chracter)\

set list may be useful later for character editing. I wouldn't recommend just deleting it without knowing what you are doing.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问