用于Intellij IDEA 14.0.x的go lang插件

是否可以为Intellij IDEA 14.0.3版本设置go语言插件?</ p>

我试图从 https://plugins.jetbrains下载二进制插件(jar) .com / plugin / 5047?pr = idea ,但此处列出的0.9.15.3版本较旧,无法识别GOROOT和GOPATH。
我尝试使用 https://github.com/go-lang-plugin-org/go-lang-idea- </ b>

是否有可用的最新版本的go lang插件二进制版本?</ p>
</ div>

展开原文

原文

Is it possible to setup go language pluing for Intellij IDEA 14.0.3 version?

I tried to download the binary plugin (jar) from https://plugins.jetbrains.com/plugin/5047?pr=idea but the version 0.9.15.3 listed here is old and does not recognize GOROOT and GOPATH. I tried to build the latest plugin using sources from https://github.com/go-lang-plugin-org/go-lang-idea-plugin using Intellij but failed to setup the SDK.

Is there a latest binary version of the go lang plugin available?

doumengbai2031
doumengbai2031 您不能将社区版用于Go开发吗?(除此之外,从14.0到14.1的更新不是免费的吗?)
大约 5 年之前 回复
douting0585
douting0585 资金限制:)
大约 5 年之前 回复
du7535
du7535 也许最好安装LiteIDE
大约 5 年之前 回复
dongmin4052
dongmin4052 为什么不更新Intellij?
大约 5 年之前 回复

2个回答



更新到IDEA 14.1+或使用IntelliJ社区。</​​ p>

原始答案:
您可以 将IntelliJ Community的免费版本与最新版本的插件一起使用,一切正常。 此外,例如Android Studio也与该插件兼容。
不幸的是,该插件具有一些内部依赖性,这使得移植和维护多个IDEA版本变得困难。 希望对您有帮助</ p>
</ div>

展开原文

原文

Update to IDEA 14.1+ or use the IntelliJ Community.

Original answer: You can use the free version of IntelliJ Community with the latest version of the plugin and everything should work fine. Also, Android Studio for example is compatible with the plugin as well. Unfortunately the plugin has some internal dependencies which makes it hard to port back and maintain for multiple IDEA versions. Hope this helps

I also faced up this problem couple days ago. You can download nightly version of go plugin from this link.

You must install this plugin via browse your download folder not repository

douxiezha9319
douxiezha9319 但这不是应该怎么做。 确实可以从网站上手动下载它,但您应该阅读自述文件并将alpha / nightly存储库添加到IDE中。 另外,我们也不再支持14.0.x分支,因为它太复杂了(很快IDEA 15就会出现)。
大约 5 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问