使用brew安装fluxctl [关闭]

I'm trying to install fluxctl using brew but got the following error:

go: downloading golang.org/x/sync v0.0.0-20190227155943-e225da77a7e6
go: extracting golang.org/x/sync v0.0.0-20190227155943-e225da77a7e6
    build github.com/weaveworks/flux/cmd/fluxctl: cannot load github.com/docker/distribution: reading https://proxy.golang.org/github.com/2opremio/distribution/@v/v0.0.0-20190419185413-6c9727e5e5de.zip: 400 Bad Request

Also, I tried to: 1) uninstall go and then install the updated version "1.12.6" but still got the same error. 2) brew update & brew doctor

P.S.using WSL (windows 10)

2个回答



我通过使用brew“ brew install go”安装go解决了问题</ p>

它给了我 错误</ p>

 错误:已安装go HEAD-6a9b22c 
要安装1.12.6,请先运行“ brew unlink go
</ code> </ pre>

然后我运行 brew unlink go </ code>,然后再次
brew install go </ code>。</ p>

我确保我拥有正确的版本 通过运行</ p>

  $ whereis go 
go:/ usr / local / go /home/linuxbrew/.linuxbrew/bin/go

$ go version
go版本go1 .12.6 linux / amd64
</ code> </ pre>

然后成功安装了“ brew install fluxctl”!</ p>
</ div>

展开原文

原文

I solved the problem by installing go using brew "brew install go"

It gave me an error

Error: go HEAD-6a9b22c is already installed
To install 1.12.6, first run `brew unlink go

then I run brew unlink go then brew install go again.

I made sure I have the right version by running

$ whereis go
go: /usr/local/go /home/linuxbrew/.linuxbrew/bin/go

$ go version
go version go1.12.6 linux/amd64

Then "brew install fluxctl" successfully installed!



问题出在包本身:</ p>

URL 下载无效</ p>

返回:</ p>

 :无效版本
</ code> </ pre>

,您可以尝试 直接使用二进制 </ p>
< / DIV>

展开原文

原文

the problem is from the package itself:

the version in URL download is not valid

it returns:

not found: invalid version

you can try to it directly using the Binary

drgd73844
drgd73844 感谢您为我提供解决方案的线索!
一年多之前 回复
douduidui1046
douduidui1046 您可以尝试使用二进制文件进行安装:github.com/weaveworks/flux/releases/download/1.13.0/…
一年多之前 回复
dongzaliang4492
dongzaliang4492 我怎样才能解决这个问题? 我只是运行“ brew install fluxctl”
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐