SFAfreshman
2019-12-25 21:23
采纳率: 85.7%
浏览 622
已采纳

开发文档jdk版本和java jdk版本什么关系?我网上找的开发文档是jdk1.8,但是电脑上javajdk版本是12.0

开发文档jdk版本和java jdk版本什么关系?我网上找的开发文档是jdk1.8,但是电脑上javajdk版本是12.0?
学习中碰到了好几次jdk更新之前能用的api都不能用了
网上看到有人说jdk1.8是最好用的

问题过于小白还望各位大佬赐教QAQ
图片说明图片说明
图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • 世纪怪咖 2019-12-26 08:41
    已采纳

    java8之后算是一个转折点吧,其实你说的那个包在java8里面虽然可以用,但是java也不建议用,那是供java内部开发使用的,有警告说之后的版本可能会删除

    点赞 评论
  • blownewbee 2019-12-25 23:34

    这是对应的关系,因为api的发展是渐进的,并且向下兼容,所以就基本功能来说,旧文档也凑合看,一些新增的函数没有。

    点赞 评论

相关推荐 更多相似问题