IntelliJ IDEA 2019 不支持JDK1.5?

公司有一个老的项目,使用IDEA2019无法编译

项目情况:web工程(非maven项目),jdk1.5,tomcat5.5,struts。

网上所有的情况都试过了,是不是IDEA放弃JDK1.5了?

报错:

图片说明

项目设置:

1

图片说明

2

图片说明

3

图片说明

idea设置:

图片说明

按照官网所说设置成jdk1.5,idea无法启动,报版本过低!

https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

图片说明

2个回答

我用idea2020,用jdk1.5,javac5,结果自动用的javac11,编译失败。用jdk1.6,javac5编译,就编译成功了

SDK用1.8,其他不变

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐