weixin_44197665 2020-02-06 17:48 采纳率: 50%
浏览 1598
已采纳

python3无法安装turtle模块。

python3中没有自带turtle模块,使用pip install也无法安装turtle

图片说明

通过百度了解到可能是因为turtle-0.0.2中setup.py的第四十行存在语法错误(python2的语法格式是没有括号的,但是python3没有括号就会报错) 语法错误,已经尝试过通过把turtle-0.0.2包下载到本地后自己给setup.py的第四十行加上括号然后再本地安装
但是还是出现了另一个报错

图片说明

告诉我到底怎么能装上turtle模块就行了

  • 写回答

2条回答 默认 最新

  • 「已注销」 2020-02-06 18:02
    关注

    anconda3可以给你默认装好,不过还是导入时还是会报错,需要再解决一下

    https://blog.csdn.net/qq_43452181/article/details/100691619

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 关于模型训练的一个问题
  • ¥15 装了几千台服务器从来没遇到这种问题,哎看下哪位帮我解决吧
  • ¥15 单片机程序上的困难问题
  • ¥15 请教某软件缓存Ts文件破解合并mp4的方法
  • ¥15 求小游戏炸弹人中关于敌人的C++代码
  • ¥15 拿到这个服务器最高权限有偿
  • ¥50 来个抓app跳转支付宝转链接的
  • ¥15 remotes安装提示没有description文件
  • ¥15 AttributeError: 'NoneType' object has no attribute 'drop_duplicates'报错
  • ¥15 以下代码,运行结果报错