kolla安装单节点openstack rocky版本过程中报错。

kolla-ansible prechecks -i /openstack/kolla-deploy/all-in-one验证部署状态
,在验证前期准备这一过程中,报了如下错误:

TASK [prechecks : Checking docker SDK version] ******************************************
fatal: [localhost]: FAILED! => {"changed": false, "cmd": ["/usr/bin/python", "-c", "import docker; print docker.__version__"], "delta": "0:00:00.456509", "end": "2020-03-03 11:00:50.188186", "failed_when_result": true, "rc": 0, "start": "2020-03-03 11:00:49.731677", "stderr": "", "stderr_lines": [], "stdout": "1.10.6", "stdout_lines": ["1.10.6"]}
fatal: [allinone]: FAILED! => {"changed": false, "cmd": ["/usr/bin/python", "-c", "import docker; print docker.__version__"], "delta": "0:00:00.368353", "end": "2020-03-03 11:00:50.167966", "failed_when_result": true, "rc": 0, "start": "2020-03-03 11:00:49.799613", "stderr": "", "stderr_lines": [], "stdout": "1.10.6", "stdout_lines": ["1.10.6"]}

一开始百度到的解决办法是,kolla版本与docker-python版本不兼容。于是我把docker-python版本需要升级到高版本的,但是升级了依旧是报这个错误。不知道是什么原因,太难了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问