ubuntu下如何在已有python版本上安装anaconda?

ubuntu上预装python版本为3.5,由于需要使用faiss,安装了anaconda,但是anaconda中python版本是3.7。

安装faiss后发现原有python3.5仍然无法使用faiss,而使用conda安装python3.7的其他包会报错,因此python3.5和3.7都不能正常使用。

能否利用anaconda给原有的python3.5安装faiss?

或者能否在不卸载python3.5的情况下解决python3.7安装包失败的问题?

下图为conda安装python3.7包时错误信息

图片说明

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问