Android Studio在 dependencies 块下添加recyclerview依赖出现错误Error:unable to resolve dependency for ':app@debug/compileClasspath':Could not resolve androidx.recyclerview:recyclerview:1.1.0.

在dependencies块里添加其它的依赖都会报错,有没有大佬知道这是为什么啊,这个已经折磨我一个星期了T T..

图片说明

图片说明

图片说明

1个回答

gradle 是不是选了 offline,或者写了代理,也有可能你是以前在host做了些什么修改

最好加上淘宝的源试试

buildscript {
    repositories {
        maven{ url 'http://maven.aliyun.com/nexus/content/groups/public/'}
        google()
        jcenter()

    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.4.1'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        maven { url 'http://maven.aliyun.com/nexus/content/groups/public/' }
        maven { url 'http://maven.aliyun.com/nexus/content/repositories/jcenter' }
        maven { url 'http://maven.aliyun.com/nexus/content/repositories/google' }
        maven { url 'http://maven.aliyun.com/nexus/content/repositories/gradle-plugin' }
        google()
        jcenter()

    }
}

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问