pycharm创建项目时,解释器总是显示旧版python

之前电脑安装过Python3.7,后来卸载后安装了Python3.8.2,原因是看到介绍说Python3.8比较快一点嘛,但是pycharm创建虚拟项目的时候,默认的Python解释器总是3.7的,怎么也改不过来,麻烦大神给解决下

图片说明

图片说明

1个回答

file - settings project interpreter Add Local 定位选择你新安装的 python

lianisgood
lian@qiao 这个问题自己解决啦,重新安装pycharm最新版后可以了,想到问题应该是在电脑的个人文件夹的pycharm配置文件夹里面有旧版缓存,具体在哪里找不到,删除该文件夹的话,pycharm就需要重新激活了
4 个月之前 回复
seakingx
陈年椰子 回复lian@qiao: 参考这个 https://blog.csdn.net/weixin_43794311/article/details/104438871, settings只加主解释器 3.8,再添加外部解释器 3.7
5 个月之前 回复
lianisgood
lian@qiao 回复陈年椰子: 好像还是不行,还是显示3.7
5 个月之前 回复
seakingx
陈年椰子 回复lian@qiao: 在 settings 里 试试删掉旧版,在添加。 或者删掉新版再添加。 应该是按添加的顺序显示的。
5 个月之前 回复
lianisgood
lian@qiao 想知道的是如何在创建项目的时候默认为3.8.2,而不是每次都要重新选择
5 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐