Ubuntu交叉编译QT5.9.9时指定了OpenGL路径但配置configure时依旧报错未指定路径

qmake.conf的对OpenGL的配置是:

QMAKE_INCDIR_OPENGL     = /opt/ArmLinux/opengl/include
QMAKE_LIBDIR_OPENGL     = /opt/ArmLinux/opengl/lib
QMAKE_INCDIR_EGL        = $$QMAKE_INCDIR_OPENGL/EGL
QMAKE_LIBDIR_EGL        = $$QMAKE_LIBDIR_OPENGL
QMAKE_INCDIR_OPENGL_ES2 = $$QMAKE_INCDIR_OPENGL
QMAKE_LIBDIR_OPENGL_ES2 = $$QMAKE_LIBDIR_OPENGL
QMAKE_INCDIR_OPENVG     = $$QMAKE_INCDIR_OPENGL
QMAKE_LIBDIR_OPENVG     = $$QMAKE_LIBDIR_OPENGL

QMAKE_LIBS_EGL         += -lEGL
QMAKE_LIBS_OPENGL_ES2  += -lGLESv2 -lEGL -lGAL
QMAKE_LIBS_OPENVG      += -lOpenVG -lEGL -lGAL

configure的配置:

#!/bin/sh  
./configure \
-prefix /opt/ArmLinux/QT5.9-ARM-Linux \
-xplatform linux-arm-gnueabi-g++ \
-release \
-opensource \
-verbose \
-make libs \
-no-xcb \
-no-dbus \
-nomake tests -nomake examples -nomake tools \
-no-opengl -opengl es2 -no-openssl \
-qt-zlib -qt-libjpeg -qt-libpng \
-confirm-license \
-skip qtdoc \
-skip qtgamepad \
-skip qtwayland \
-skip qtwebchannel \
-skip qtwebengine \
-skip qtwebsockets \
-skip qtwebview \
-skip qtandroidextras \
-skip qtwinextras \
-skip qtmacextras \
-skip qtpurchasing \
# -I /opt/ArmLinux/opengl/include 在这里加上路径也是一样会报错
# -L /opt/ArmLinux/opengl/lib

而且也安装了libgles2-mesa、libgles2-mesa-dev

OpenGL库的路径也没有错:

include:
图片说明

lib:

图片说明

但配置的时候出错了:

ERROR: Feature 'opengles2' was enabled, but the pre-condition 'config.win32 || (!config.watchos && !features.opengl-desktop && libs.opengl_es2)' failed.

ERROR: The OpenGL functionality tests failed!
You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.

不知道问题出在哪里,有没有大佬知道怎么解决?

4个回答

weixin_42350844
晒太阳 如果是需要opengl的情况下呢
4 个月之前 回复

看看那个config.log中有关于opengles库验证相关的更细节的错误啊

weixin_42350844
晒太阳 我的config.log里面只有输入的命令怎么办呢
4 个月之前 回复

我也是同样的错误,但是我第一次安装了opengl库的时候是没有报错的(第一次编译qt没有通过),再后来configure都有这个opengl的错误。我并不知道我apt-get install opengl相关的库以后路径在哪里,所以放弃了。只能在configure里 加上 -no opengl。
另外我听说了一个方法,你可以尝试下,把opengl-desktop 去掉,试一试。我估计是configure 后面加 -no opengl-desktop

qq_37440204
MonoKelvin 我之前在stack overflow也看到过这种办法,但我试过并没有起作用。后来看到有说要开发板内置的opengl库和其他一些库同时编译进去才可能有用。
4 个月之前 回复

这边回来了,我用了buildroot出来的sysroot,之前也是同样的问题。可能是没有下载对应版本的opengl库

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问