MY1115
MY1115
2020-05-05 14:10
采纳率: 90%
浏览 260
已采纳

在用tomcat7.0运行web项目,会出现状态码500:Unable to compile class for JSP ,而用tomcat9.0就能正常运行,原因是?

在用tomcat7.0运行web项目,会出现状态码500:Unable to compile class for JSP ,而用tomcat9.0就能正常运行,原因是?
tomcat版本为什么会造成这种影响?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • wojiushiwo945you
    毕小宝 2020-05-05 18:09
    已采纳

    Tomcat 7 和 jdk 8 是不兼容的,所以需要用与 JDK 版本兼容的的 Tomcat 。
    如果用的tomcat是低版本的,但是用的jdk却是高版本的,用Servlet做的项目运行都没有问题,但是直接运行jsp 就存在编译问题。
    Tomcat 和 JDK 的对应关系为:

    tomcat v7.0--Java EE 5 and 6
    tomcat v8.0--Java EE 5,6 and 7
    tomcat v8.5--Java EE 5,6 and 7
    tomcat v9.0--Java EE 5,6,7 and 8
    
    点赞 评论
  • caozhy

    https://www.cnblogs.com/ygj0930/p/6383192.html
    看你引用的jdk包和你的jvm是否兼容,不兼容就修改下

    点赞 评论

相关推荐