g327513353
g327513353
采纳率0%
2020-05-26 18:22

maven构建的项目采用jdk13compile报错,换成jdk1.8正常运行

最近照某培训机构的项目敲,该项目采用的是jdk1.8,由于我从一开始就用的jdk13,
所以就还是用的jdk13,今天在IDEA里用maven构建项目时,突然发现每一个子模块都不能
compile成功,错误提示也都是-----不支持的发行版:13。

各种百度后,都说是jdk版本不对应的问题。

于是,我检查了我的IDEA的所有JDK版本的设置,以及maven的setting.xml文件中的设置,均为jdk13。

因此应该不是这个问题,于是我将maven的setting.xml文件中默认的compile全部改为jdk1.8,IDEA的设置没有更改,均为jdk13,之后maven编译,发现项目编译通过了!!!!

我非常不明白是什么原因,有没有大佬给解释一番,跪谢

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

相关推荐