安装了支持MySQL的Zabbix4.0,在安装配置前端页面时在页面却显示只支持PostgreSQL

版本信息: Ubuntu-18.04 MySQL-5.7.30 Zabbix-4.0.21 Apache2 PHP7.2

安装了支持MySQL的Zabbix4.0,在安装配置前端页面时在页面却显示只支持PostgreSQL,但是我的服务器中并没有安装PostgreSQL,只安装了MySQL

安装过程的全部代码:

#============安装MySQL============
sudo apt-get update
sudo apt-get install -y mysql-server
sudo apt-get install -y mysql-client
sudo apt-get install -y libmysqlclient-dev

#设置 root@localhost 密码,做以下操作
ROOT_PASSWORD=`cat /dev/urandom | tr -dc A-Za-z0-9 | head -c 8`
echo "ROOT_PASSWORD = ${ROOT_PASSWORD}" >> ~/mysql-passwd
sudo mysql -e "update mysql.user set authentication_string=PASSWORD('${ROOT_PASSWORD}'), plugin='mysql_native_password' where user='root';"
sudo mysql -e "flush privileges;"

#配置mysql远程登录
#修改配置文件/etc/mysql/mysql.conf.d/mysqld.cnf,注释掉bind-address = 127.0.0.1
sudo sed -i 's/bind-address/#bind-address/g' /etc/mysql/mysql.conf.d/mysqld.cnf

#保存退出,然后进入mysql服务,执行授权命令,给予 root@'%' 添加权限--远程登录用户和密码
longrange_passwd=`cat /dev/urandom | tr -dc A-Za-z0-9 | head -c 8`
echo "longrange_passwd = ${longrange_passwd}" >> ~/mysql-passwd
mysql -uroot -p"${ROOT_PASSWORD}"  -e "grant all on *.* to root@'%' identified by '${longrange_passwd}' with grant option;"
mysql -uroot -p"${ROOT_PASSWORD}"  -e "flush privileges;"

#修改数据库编码为utf-8
echo 'default-character-set=utf8' | sudo tee -a /etc/mysql/conf.d/mysql.cnf
echo 'character-set-server=utf8' | sudo tee -a /etc/mysql/mysql.conf.d/mysqld.cnf

#重启mysql服务
sudo systemctl restart mysql.service 

#设置mysql开机自启动
sudo update-rc.d mysql defaults
#取消开机自启动: update-rc.d -f mysql remove

#============安装配置Zabbix-server============
#创建目录
mkdir -p ~/download
mkdir -p ~/application
mkdir -p ~/scripts

#创建zabbix数据库
cd
ROOT_PASSWORD=`cat  ~/mysql-passwd|grep 'ROOT_PASSWORD'|awk -F '[ ]' '{print $3}'`
zabbix_passwd=`cat /dev/urandom | tr -dc A-Za-z0-9 | head -c 8`
echo "zabbix_passwd = ${zabbix_passwd}" >> ~/mysql-passwd
mysql -uroot -p"${ROOT_PASSWORD}" -e "create database zabbix character set utf8 collate utf8_bin;"
mysql -uroot -p"${ROOT_PASSWORD}" -e "grant all privileges on zabbix.* to zabbix@localhost identified by '${zabbix_passwd}';"
mysql -uroot -p"${ROOT_PASSWORD}" -e "flush privileges;"

#安装zabbix
cd ~/download
wget https://repo.zabbix.com/zabbix/4.0/ubuntu/pool/main/z/zabbix-release/zabbix-release_4.0-2+bionic_all.deb
sudo dpkg -i zabbix-release_4.0-2+bionic_all.deb
sudo apt-get update

#安装 Server/proxy/前端
sudo apt-get install -y zabbix-server-mysql    #安装 Zabbix server 并使用 MySQL 数据库
sudo apt-get install -y zabbix-frontend-php    #安装 Zabbix 前端
#==sudo apt-get install -y zabbix-proxy-mysql     #安装 Zabbix proxy 并使用 MySQL 数据库

#导入数据库数据--初始数据库 schema 和数据
zabbix_passwd=`cat  ~/mysql-passwd|grep 'zabbix_passwd'|awk -F '[ ]' '{print $3}'`
zcat /usr/share/doc/zabbix-server-mysql/create.sql.gz | mysql -uzabbix -p${zabbix_passwd} zabbix

#Zabbix proxy,导入初始的数据库 schema
#==zcat /usr/share/doc/zabbix-proxy-mysql/schema.sql.gz | mysql -uzabbix -p${zabbix_passwd} zabbix

# Zabbix server/proxy 配置数据库
sudo sed -i 's/# DBHost=localhost/DBHost=localhost/g' /etc/zabbix/zabbix_server.conf
sudo sed -i 's/# DBUser=/DBUser=zabbix/g' /etc/zabbix/zabbix_server.conf
zabbix_passwd=`cat  ~/mysql-passwd|grep 'zabbix_passwd'|awk -F '[ ]' '{print $3}'`
sudo sed -i "s/# DBPassword=/DBPassword=${zabbix_passwd}/g" /etc/zabbix/zabbix_server.conf

#启动 Zabbix server 进程,并使其开机自启
sudo service zabbix-server start
sudo update-rc.d zabbix-server enable

#Zabbix 前端配置,配置时区
sudo sed -i "s/# php_value date.timezone Europe\/Riga/php_value date.timezone Asia\/Shanghai/g" /etc/apache2/conf-enabled/zabbix.conf

#重启apache服务
sudo service apache2 restart

#============安装配置Zabbix-agent============
#安装 Agent
sudo apt-get install -y zabbix-agent

#启动zabbix-agent,并使其开机自启
sudo service zabbix-agent start
sudo update-rc.d zabbix-agent enable

#Zabbix初始登录用户和密码为 Admin 和 zabbix
#数据库密码在当前用户的 mysql-passwd 文件中

前段页面显示只支持pgsql:
图片说明
图片说明
请问这个如何解决?谢谢!

1个回答

我也出现了这个情况,检查了php的安装项,发现少了mysql的支持包
使用

```apt-install php7.3-mysql

就行了,如果发现连接超时再在后面加个--fix-missing

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问