蛋蛋ii
2020-06-18 20:25
采纳率: 100%
浏览 324

用小黑窗安装pygame报这个错

Downloading pygame-1.9.6-cp37-cp37m-win_amd64.whl (4.3 MB)
|████████████████████▌ | 2.7 MB 7.0 kB/s eta 0:03:36
ERROR: THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pygame from https://files.pythonhosted.org/packages/ed/56/b63ab3724acff69f4080e54c4bc5f55d1fbdeeb19b92b70acf45e88a5908/pygame-1.9.6-cp37-cp37m-win_amd64.whl#sha256=8da13704ad45b7d5de8a8cca135a7f44c7fc6aa9f691abe7b0392468a34a8013:
Expected sha256 8da13704ad45b7d5de8a8cca135a7f44c7fc6aa9f691abe7b0392468a34a8013
Got 41395ad50c3dc1f4c45c223c4a63308691801b630fc3793b73960f0c2cf24384

报这个cuo

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • mollpppp 2020-06-18 21:00
    已采纳

    你安装的这个pygame,包管理系统认为他的hash(哈希)值与记录的hash值不匹配,认为这个包可能有问题。
    他建议你检查这个包,确信获取的路径是可信的,或者更新本地的hash记录文件。
    可以尝试如下方法:1.更新包管理软件,2.选择可信路径下载 3.忽略校验

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题