aboyknownothing
风&~★`飘逸
2020-08-22 17:31
采纳率: 50%
浏览 1.2k

python中导入import matplotlib.pyplot as plt 报错应该怎么解决?

最近刚刚搞定了tensorflow深度学习的环境问题,最近在绘图时有出现了新的问题。

import matplotlib.pyplot as plt

在运行这一行之后,返回了报错:

---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-2-a0d2faabd9e9> in <module>
----> 1 import matplotlib.pyplot as plt

d:\python36\lib\site-packages\matplotlib\__init__.py in <module>
    137 # definitions, so it is safe to import from it here.
    138 from . import cbook, rcsetup
--> 139 from matplotlib.cbook import (
    140     MatplotlibDeprecationWarning, dedent, get_label, sanitize_sequence)
    141 from matplotlib.cbook import mplDeprecation  # deprecated

ImportError: cannot import name 'dedent'

在其他人的问答区发现了类似的问题,说是matplotlib 版本的问题,但是我3.3.1的版本降到3.0.0还是无法解决。

我怀疑原因可能出在最近我安装过一次anaconda,之后又卸载掉了,有没有可能是卸载的时候连带着把matplotlib的东西删掉了呢?但是想了一想也不太可能,因为我设置的安装路径还是完全不同的。所以恳求各位专业人士能够告诉我问题出在哪里,万分感谢!!!!!!!

分界线
终于找到问题出在哪里了,感谢评论区朋友的建议,我尝试直接在python里输入这行代码,发现是可以运行的,但是问题就是系统会返回一句
大概是说
libopenblas.PYQHXLVVQ7VESDPUVUADXEVJOBGHJPAY.gfortran-win_amd64文件在某个文件夹出现了两次导致错误的语句。
于是我尝试着找到那个文件夹,然后删除了其中之一,再尝试运行就不报错了!!!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • jingluan666
    jingluan666 2020-08-22 18:47
    已采纳

    我用python3.6安装3.3.1的matplotlib正常,说明是其他原因,要不然新建一个项目试下,只安装这个

    点赞 评论

相关推荐