安装pandas 失败(使用国内镜像) Getting requirements to build wheel ... error

图片说明

2个回答

https://blog.csdn.net/weixin_46847476/article/details/105346569
里面的第三点就有解决方案

这种错误造成的原因仍然是setuptools的版本太低,只不过是它的另一种表现形式,新版本的setuptools有新功能,pip下载的时候会使用最新的下载途径,就会用到这个新功能,然而如果你的版本较低,就没有这个功能,然后就会报错;
AttributeError: module ‘setuptools.build____meta’ has no attribute ‘__legacy__’,你的电脑可能报的不一定是’__legacy__’,但是原因还是一样的,要更新setuptools,使用指令:
pip install --upgrade setuptools

weixin_44229243
种程序的小白菜 感谢!之前已经尝试过了,setuptools已经是最新version,还有wheel也已经安装过。但是并没有从这一思路成功解决问题。之后采用了安装包下载之后安装。
15 天之前 回复

先安装wheel后再安装pandas试试
pip install wheel -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com

weixin_44229243
种程序的小白菜 谢谢
15 天之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐