感谢好心人士帮忙解答以下问题,最后能编出完整代码。感谢!!
都说两点确定一条直线,那么设计一个直线类Line,需要通过两个点Point对象来确定。Line类具体要求如下:
1)定义两个Point对象p1,p2;
2)写出有参构造方法,传递两个对象值给p1,p2
3)为p1,p2写出setters,和getters方法
4)为Line写出一个getLength方法求直线中两点的长度
5) 为Line写一个ToString方法,方法如下所示:
public String toString() { return "Line [p1=" + p1 + ", p2=" + p2 + "]"; }
在Main类的main方法中,定义一个Line数组,数组长度通过键盘给出,然后通过键盘为每线段的两个Point对象的坐标赋值,并生成相应Line对象放入数组中,循环数组,输出每条直线的信息,以及两个点之间的距离。
Point 类如下所示:
public class Point {
private int x, y;// x,y为点的坐标
//求两点之间的距离
public double distance(Point p1) {
return Math.sqrt((p1.x -this.x)(p1.x -this.x)+(p1.y-this.y)(p1.y-this.y));
}
public Point(int x, int y) {
super();
this.x = x;
this.y = y;
}
public int getX() {
return x;
}
public void setX(int x) {
this.x = x;
}
public int getY() {
return y;
}
public void setY(int y) {
this.y = y;
}
public Point() {
super();
x = y =0;
}
@Override
public String toString() {
return "Point [x=" + x + ", y=" + y + "]";
}
}
输入格式:
第一行输入数组的长度n 每一行输入一个Line对象的两个点对象的 x y的坐标,中间用空格隔开
输出格式:
循环输出,输出直线的信息,以及每条直线的两个点的距离,保留一位小数。
输入样例:
在这里给出一组输入。例如:
2
0 0 2 3
1 3 2 5
输出样例:
在这里给出相应的输出。例如:
Line [p1=Point [x=0, y=0], p2=Point [x=2, y=3]]
此线段的长度为:3.6
Line [p1=Point [x=1, y=3], p2=Point [x=2, y=5]]
此线段的长度为:2.2
Java中关于子类继承的一个实例问题(关于两点确定一条直线),感谢好心人士帮忙回答
- 写回答
- 好问题 0 提建议
- 追加酬金
- 关注问题
- 邀请回答
-
1条回答 默认 最新
- qq_51536474 2021-01-04 19:15关注
import java.util.Scanner; public class Main { public static void main(String[] args) { // TODO Auto-generated method stub Scanner iScanner=new Scanner(System.in); line line1=new line(); int b=iScanner.nextInt(); double[] a=new double[b]; int z[][]=new int[b][4]; for (int i = 0; i < z.length; i++) { for (int j = 0; j < z[i].length; j++) { int c=iScanner.nextInt(); z[i][j]=c; } } for (int i = 0; i < z.length; i++) { line1.p1=new Point(z[i][0],z[i][1]); line1.p2=new Point(z[i][2],z[i][3]); a[i]=line1.getLength(line1.p1,line1.p2 ); System.out.println(line1.toString()); System.out.printf("此线段的长度为:%.1f",a[i]); System.out.println(); } } } class Point { int x;// x,y为点的坐标 int y; //求两点之间的距离 Point p1,p2; public double distance(Point p1) { return Math.sqrt((p1.x -this.x)*(p1.x -this.x)+(p1.y-this.y)*(p1.y-this.y)); } public Point(int x, int y) { super(); this.x = x; this.y = y; } public int getX() { return x; } public void setX(int x) { this.x = x; } public int getY() { return y; } @Override public String toString() { return "Point [x=" + x + ", y=" + y + "]"; } public void setY(int y) { this.y = y; } public Point() { super(); x = y =0; } } class line extends Point{ public double getLength(Point p1,Point p2) { return Math.sqrt((p1.x -p2.x)*(p1.x -p2.x)+(p1.y-p2.y)*(p1.y-p2.y)); } public String toString() { return "Line [p1=" + p1 + ", p2=" + p2 + "]"; } }
PTA以通过,欢迎关注我嗷~
本回答被题主选为最佳回答 , 对您是否有帮助呢?解决 1无用
悬赏问题
- ¥30 微信小程序蓝牙数据透传
- ¥15 加氢站氢负荷数据集来源
- ¥15 umi接入sentry遇到问题
- ¥15 HBuilderX打包H5网页,扫码模块无法使用
- ¥15 Javascript跳转页面后,无法执行后面代码,如何解决?
- ¥15 echarts绘制图表
- ¥15 请教两个关于高德地图定位不准的技术问题
- ¥15 根据企业名称 对照两个文件 样本筛选/匹配
- ¥15 Linux环境下CA证书更新问题
- ¥15 sqlserver语句提取结果以外数据