2 wqh8264351 wqh8264351 于 2013.07.12 16:42 提问

phpmailer错误提示You must provide at least one recipient email address

在实际工作中用到的phpmailer功能,但是在发送邮件的时候有些时候出现提示You must provide at least one recipient email address错误,但是我email是从数据库提取的。。而且我自己编写一个程序将数据库所有的邮件与phpmailer正则表达式进行过匹配都是没有问题,请问有没有PHP大神知道这个是为什么?什么情况会发生这样的问题

1个回答

fbcha
fbcha   2014.02.04 18:05
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
thinkphp 发送邮件
class IndexAction extends Action {  public function page(){  require('class.phpmailer.php');     $email = '52789534@qq.com';         $mail = new PHPMailer();     $mail->IsSMTP();     $mail->
WorkSpace使用-与Library结合
WorkSpace使用(与Library结合) WorkSpace是Xcode提供的便于群组化管理项目工程的一个工作区间,我们可以把有关联的项目放到同一个工作区中,进行联合编译或者其它操作等。WorkSpace是XCode4引入,在XCode3中工作流被限制在单一的项目工程中,在之后的版本中可以把工作流相关的若干个项目工程放到同一个工作区中。当然WorkSpace应该还有更广阔的应用,本文暂
Error creating assembly archive pack: You must set at least one file.
今天用maven的assembly插件打包,发现了一个bug,打包后会报下面的错: Error creating assembly archive pack: You must set at least one file. 找来找去发现是因为项目中依赖的第三方jar没有在代码中用到,所以assembly打dependencies 包的时候会报错,把依赖加进去后,就可以了。
java.lang.IllegalArgumentException: At least one handler method must be found in class [class SayThr
log4j:WARN No appenders could be found for logger (org.springframework.context.support.ClassPathXmlApplicationContext). log4j:WARN Please initialize the log4j system properly. java.lang.IllegalArgum
You must specify at least one directory for a flat directory repository.
You must specify at least one directory for a flat directory repository.配置gradle时出现这个错误,repositories { flatDir { //dirs 'libs' } }是不小心把libs注释掉了,去掉注释就ok了...
Hibernate Tools Reference Guide
Hibernate Tools Reference GuidePrefaceHibernate Tools is a toolset for Hibernate 3 and related projects. The tools provide Ant tasks and Eclipse plugins for performing reverse en
Ubuntu pip安装tensorflow出现错误怎么解决啊
~$ sudo pip3 install --upgrade $TF_BINARY_URLThe directory '/home/yang/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permi...
Caused by: java.lang.IllegalArgumentException: At least one JPA metamodel must be present!
使用spring boot对老项目改造, spring boot 启动报错 Caused by: java.lang.IllegalArgumentException: At least one JPA metamodel must be present! 估计是跟多个数据源有关,改成如下这样就可以了 @SpringBootApplication @EnableAutoConfigur
关于安装Ubuntu的vmtools,在用解压命令tar -zvzf VM....时出现 you must specify one of the 'Acdtrux......的解决办法
可以将命令改为  tar -xf VM...试一下,我是用这种方法解决的
jpa使用 at least one user library must be selected问题
at least one user library must be selected实际就是建立一个目录,导入三个包即可 ①、 eclipselink.jar ②、javax.persistence.source_2.1.0.v201304241213.jar ③、javax.persistence_2.1.0.v201304241213.jar (注:本系列笔记是在学习尚硅谷JPA课程的