weixin_39670857
weixin_39670857
2020-11-22 00:15

Failed to resolve: com.twitter.sdk.android:twitter:1.8.0

Hi there, i am trying to add the twitter sdk into my library in android. But, it is always said that failed to resolve the library. But if i tried to add the twitter sdk into my application (not library) it is ok. Could you please help? Thanks.

该提问来源于开源项目:twitter-archive/twitter-kit-android

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • weixin_39670857 weixin_39670857 5月前

    I have followed the steps here: http://support.crashlytics.com/knowledgebase/articles/456258-library-subproject-in-gradle But it still doesn't work

    点赞 评论 复制链接分享
  • weixin_39640767 weixin_39640767 5月前

    I've both tried manually following the above steps and tried installed the Fabric Plugin to auto configure the build files onto Android studio and I'm having this issue as well.

    点赞 评论 复制链接分享
  • weixin_39670857 weixin_39670857 5月前

    You need to put this in the main app too

     Gradle
    repositories {
        maven { url 'https://maven.fabric.io/repo' }
    }
    
    点赞 评论 复制链接分享
  • weixin_39640767 weixin_39640767 5月前

    Great!

    I was just confused as some other docs had only /public

    Joseph Zhong

    On Wed, Oct 7, 2015 at 11:59 PM -0700, "Elsen Novraditya" notifications.com wrote: You need to keep this in the main app

     Gradle
    repositories {
        maven { url 'https://maven.fabric.io/repo' }
    }
    

    Reply to this email directly or view it on GitHub: https://github.com/twitter/twitter-kit-android/issues/26#issuecomment-146438686

    点赞 评论 复制链接分享
  • weixin_39604276 weixin_39604276 5月前

    https://stackoverflow.com/questions/41659272/errorfailed-to-resolve-com-twitter-sdk-androidtwitter2-3-0-android-studio

    点赞 评论 复制链接分享

相关推荐