weixin_39563827
weixin_39563827
2020-11-22 11:22

Receiver endpoints for DSMX on xlite do not go to 1000 - 2000

When binding to the Mobula7 with DSM (both 2 or X) on the Xlite with the Vantac MPM module, the endpoints shown on the radio (988-1202) do not match what is shown in betaflight. I am unable to get the endpoints for any channel to be 1000-2000. When i try to adjust the travel in the radio they go in the opposite direction of what i need. Given this problem I am unable to use DSM. If needed I can try it with other quads i have, let me know if you need that or any other info to resolve this problem. I would really like to be able to fly all my quads using the xlite and I have lots of DSM quads. I am a Spektrum user trying to convert to OPEN TX. Thx

该提问来源于开源项目:pascallanger/DIY-Multiprotocol-TX-Module

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39962770 weixin_39962770 5月前

    Which version of MPM are you using? and which config for DSM? It's normal that the endpoints in microsec of the radio does not correspond to what you have at the receiver output since the MPM is defined to work with any radio. Instead -100/+100% on any radio will correspond to -100/100% of that specific protocol. In the case of DSM there are 2 choices depending in you've configured or not DSM_MAX_THROW as explained in the doc: https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/blob/master/Protocols_Details.md#dsm---6 , check the 3rd bullet of the notes. I don't understand what you mean by: "When i try to adjust the travel in the radio they go in the opposite direction of what i need." I think you are confused... DSM does work correctly, you just need to read the doc and configure everything correctly. Pascal

    点赞 评论 复制链接分享
  • weixin_39563827 weixin_39563827 5月前

    Thx, I did see the entry on dsm_max_throw after submitting this. I’m not at home but I have the version as of this past weekend. Something like 1.1.2....22. What I mean by adjusting the travel is: on the xlite when I try to change the endpoints I can only decrease the 100 and increase the -100, when I do that the numbers in beta flight for each channel go in the wrong direction. If I still have trouble I can be more specific with screen names when I have my transmitter in hand. Btw, I was able to get flysky working perfectly but I had to upgrade to the latest version. Thanks much for the quick reply.

    Sent from my iPhone

    On Dec 12, 2018, at 10:24 AM, pascallanger wrote:

    Which version of MPM are you using? and which config for DSM? It's normal that the endpoints in microsec of the radio does not correspond to what you have at the receiver output since the MPM is defined to work with any radio. Instead -100/+100% on any radio will correspond to -100/100% of that specific protocol. In the case of DSM there are 2 choices depending in you've configured or not DSM_MAX_THROW as explained in the doc: https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/blob/master/Protocols_Details.md#dsm---6 , check the 3rd bullet of the notes. I don't understand what you mean by: "When i try to adjust the travel in the radio they go in the opposite direction of what i need." I think you are confused... DSM does work correctly, you just need to read the doc and configure everything correctly. Pascal

    — You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub, or mute the thread.

    点赞 评论 复制链接分享
  • weixin_39563827 weixin_39563827 5月前

    One other question. I see option=number of channels from 4-12. Mine is at 6 which implies something is configured wrong. What would be an invalid option? What does options refer to ? Dsmx, dsm2, etc. just trying to understand what incorrect option I could have selected, thx again

    Sent from my iPhone

    On Dec 12, 2018, at 10:24 AM, pascallanger wrote:

    Which version of MPM are you using? and which config for DSM? It's normal that the endpoints in microsec of the radio does not correspond to what you have at the receiver output since the MPM is defined to work with any radio. Instead -100/+100% on any radio will correspond to -100/100% of that specific protocol. In the case of DSM there are 2 choices depending in you've configured or not DSM_MAX_THROW as explained in the doc: https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/blob/master/Protocols_Details.md#dsm---6 , check the 3rd bullet of the notes. I don't understand what you mean by: "When i try to adjust the travel in the radio they go in the opposite direction of what i need." I think you are confused... DSM does work correctly, you just need to read the doc and configure everything correctly. Pascal

    — You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub, or mute the thread.

    点赞 评论 复制链接分享
  • weixin_39962770 weixin_39962770 5月前

    Ok you are confused as I said... "What I mean by adjusting the travel is: on the xlite when I try to change the endpoints I can only decrease the 100 and increase the -100" Obviously if you do that and like for any other models you are decreasing the range/throw which is what limit is used for, you limit the range... This is pure usage of the radio independantly of the module being used... As written in the doc I pointed you earlier and since you have left the DSM_MAX_THROW commented by default, to get 1000...2000 you must enable "extended limits" to get to the channel limits able to increase to +-125% on the OpenTX model. Again pure usage of the radio independantly of the module being used... Pascal

    点赞 评论 复制链接分享
  • weixin_39563827 weixin_39563827 5月前

    Will do, thx for the quick replies.

    Sent from my iPhone

    On Dec 12, 2018, at 1:54 PM, pascallanger wrote:

    Ok you are confused as I said... "What I mean by adjusting the travel is: on the xlite when I try to change the endpoints I can only decrease the 100 and increase the -100" Obviously if you do that and like for any other models you are decraesing the range/throw which is what limit is used for you limit the range... As written in the doc I pointed you earlier and since you have left the DSM_MAX_THROW commented by default, to get 1000...2000 you must enable extended limits to get to +-125% on the OpenTX model. Pascal

    — You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub, or mute the thread.

    点赞 评论 复制链接分享
  • weixin_39962770 weixin_39962770 5月前

    "One other question. I see option=number of channels from 4-12. Mine is at 6 which implies something is configured wrong. What would be an invalid option? What does options refer to ? Dsmx, dsm2, etc. just trying to understand what incorrect option I could have selected, thx again" What you are saying does not make any sense... I have a doubt now, are you using PPM or Serial with the module? Why do you say a number of 6 channels is wrong? Why do you talk about option which is a field that does not appear if you use Serial and select Multi/DSM? By the way the number of channel is not something you decide but it's something the RX wants/needs... This is why you even have an auto detect setting which will set the frame rate and number of channels the RX requests. Pascal

    点赞 评论 复制链接分享