2 z124 z124 于 2014.07.30 08:57 提问

tomcat 的最新版本支持jdk1.8的编译环境吗?

tomcat 的最新版本支持jdk1.8的编译环境吗?现在在搞nutch框架,很怕这种环境不匹配的问题。

1个回答

chandlearn
chandlearn   2015.05.01 00:27

我用tomcat7.0是支持的,除了配 Java_home 以外,classpath好像也要把“java_home/lib”填进去

chandlearn
chandlearn 我就是写作业陪了一下,要是和问题不完全相符,勿怪~
大约 3 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
jdk1.8+Tomcat7.0小版本无法兼容问题解决
The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files
tomcat对应jdk版本问题
一般是和jdk版本保持一致的,也就是说tomcat6用>=jdk6版本就可以了。通常情况下,可以依次类推的。tomcat8.0可以兼容jdk1.6,而tomcat6.0不可以兼容jdk1.8tomcat版本高->jdk版本低  不会出问题下载tomcat的官网,有兼容列表的;tomcat v7.0-------support-------->Java EE 5 and 6tomc...
tomcat配置最新版jdk1.8.0_25
jdk配置成功才能保证tomcat启动,
JDK 安装配置 与 Tomcat 安装配置 (jdk1.8,tomcat8)
1、下载jdk 和 tomcat  2、安装jdk 3、配置jdk环境变量 (1)在环境变量-系统变量里面新建变量:JAVA_HOME 变量值为:C:\Program Files\Java\jdk1.8.0_121   这是我的安装目录 (2) 在环境变量-系统变量里面新建变量:classpath  变量值为:.;%JAVA_HOME%\lib; 注意前面的(.) (3)在环境变量-系统
win8.1 + tomcat8 + JDK1.8 配置经验
最近需要在电脑上开发javaWeb项目,所以前置任务就是配置开发环境,但是期间遇到种种问题,请教过各路大神,最后在俺坚持下还是搞定了,哇哈哈…… 俺的电脑是win8.1系统,照以往的习惯肯定是配置JDK1.7+TOMCAT7,但是由于工作需要电脑装的JDK1.8,总不能装2个JDK吧,安装2个也可以,但是配置环境变量一定会有问题的,总不能配置2个路径吧。就用的JDK1.8+tomcat7,我用的
SSM整合(使用最新版本jar包)+Maven+jdk8+tomcat7
参考网上的教程 使用maven整合好的SSM项目
JAVA环境软件(jdk1.8+myeclipse2015+tomcat7.0)下载地址
JAVA环境软件(jdk1.8+myeclipse2015+tomcat7.0)下载地址,放置在百度云上,提供下载地址。
Tomcat与Jdk的版本匹配
1、版本匹配说明 Tomcat8只支持jdk1.7及1.7以上的jdk,否则报java.lang.UnsupportedClassVersionError:Unsupported major.minor version 51.0。 jdk1.7及以上则运行正常。 注意:同时需要知道的是,不依赖IDE开发平台启动tomcat时,需要注意项目的jdk的版本是否比环境变量的jd
dubbo在jdk1.8环境,部署tomcat问题
http://blog.wpeace.cn/2016/12/20/dubbo-admian%E7%9A%84%E6%89%93%E5%8C%85%E5%92%8C%E5%B9%B3%E5%8F%B0%E6%90%AD%E5%BB%BA/ 已保存到网盘:/学习/工具/dubbo
myeclipse10配置JDK 不支持jdk1.8,最高支持1.7
Window-->preferences,弹出preferences设置对话框。 选择Java --> Installed JREs,在这个界面你可以添加,编辑,删除jre。 在Installed JREs界面,点击add,会出现JRE Type界面,来选择jre的类型。选择standard VM。 然后点next。 在弹出的jre  definition界面,点击上面的“