2 sdfdsgffdg sdfdsgffdg 于 2014.07.31 11:14 提问

mac 刚安装的java 8 打开eclipse 提示要安装java 6

刚到的mac
安装jdk 后
下载了adt
打开 eclipse 后提示 “若要打开Eclipse,您需要 java se 6 runtime。您现在要安装一个吗”

我java -version 后
提示 jre 是有的啊 1.8

刚入手mac 不太懂 谢谢指导

2个回答

sdfdsgffdg
sdfdsgffdg   2014.07.31 12:20

修改次文件 /Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Info.plist

su 一下 修改文件权限
提示不能切换的 先 开启root账户 再设置

                <key>JVMCapabilities</key>
            <array>
                    <string>CommandLine</string>
            </array>

修改为

                <key>JVMCapabilities</key>
            <array>
                    <string>JNI</string>
                    <string>BundledApp</string>
                    <string>WebStart</string>
                    <string>Applets</string>
                    <string>CommandLine</string>
            </array>

ok 保存重启 就ok鸟

qq_24735175
qq_24735175   2017.12.05 14:47
找不到文件目录啊‘
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Mac下打开eclipse 始终提示 你需要安装Java SE 6 Runtime
出处:http://www.cnblogs.com/zhouyinhui/p/3750836.html 我的mac os 版本是10.9.2,  JDK配置得好好的,但打开eclipse时还是提示需要安装JRE 6。解决方法如下: 打开/Library/Java/JavaVirtualMachines/jdkXXXXX.jdk/Contents/Info.plist 按
Mac os 更新到Yosemite 10.10 打开eclipse时提示“您需要安装旧的java se 6 才能允许打开eclipse”
昨天升级了mac
Mac 显示需要安装旧Java SE 6运行环境才能打开"XXX"
问题描述: 今天在Mac OS上安装一个app的时候提示 “您需要安装旧 Java SE 6 运行环境才能打开 XXX” . 解决办法 从下面的链接下载javaforosx.dmg并安装,然后再执行上面出错的app,问题就可以解决了。 https://support.apple.com/kb/DL1572?viewlocale=zh_CN&locale=en_US
Mac OS 您需要安装旧 Java SE 6 Runtime运行环境才能打开“XXX” 问题
Mac OS 您需要安装旧 Java SE 6 Runtime运行环境才能打开“XXX” 问题问题描述:今天在Mac OS上安装一个app的时候提示 “您需要安装旧 Java SE 6 运行环境才能打开 XXX” ,在网上搜索了一下,有说要改app的info.plist文件的,将其中的JVMVersion改成自己机器上的版本的,但是在我的环境下修改了仍然不起作用。然后我去官网了最新的JDK版本,发...
Mac OS 您需要安装旧 Java SE 6 运行环境才能打开"Eclipse" 的问题
Mac OS 您需要安装旧 Java SE 6 运行环境才能打开“XXX” 问题 问题描述: 今天在Mac OS上安装一个app的时候提示 “您需要安装旧 Java SE 6 运行环境才能打开 XXX” ,在网上搜索了一下,有说要改app的info.plist文件的,将其中的JVMVersion改成自己机器上的版本的,但是在我的环境下修改了仍然不起作用,最后还是使用了下面的方法搞定的。 解决
mac 下安装myeclipse 提示需要安装旧Java SE 6运行环境才能打开
以上是提示,然后网上查了下,是mac系统的原因,下载个补丁差不多就可以继续安装了。补丁下载地址:https://support.apple.com/kb/DL1572?viewlocale=zh_CN&amp;amp;locale=en_USapple官方说明是这样的:Java for OS X 2015-001 会为 OS X 10.11 El Capitan、OS X 10.10 Yosemite、O...
Mac安装eclispe提示java7不符合要求需要java8的解决办法
网上我没看到有效的办法,唯一的一个说改环境变量的也是针对win的。我是把原有的jvm都删了,新安装的java8。 所以目前来看也就这一个解决办法,因为就算升级java7到java8,在终端里查看java版本也还是java7,着实让人头疼,也希望谁有更好的办法。
您需要安装旧 Java SE 6 运行环境才能打开“eclipse”解决
升级mac系统后,打开eclipse突然提示“您需要安装旧 Java SE 6 运行环境才能打开eclipse” 解决方法: 去苹果官网下载适合该系统的jdk版本 https://support.apple.com/kb/DL1572?viewlocale=zh_CN&locale=en_US
Mac OS 您需要安装旧 Java SE 6 运行环境才能打开“XXX” 问题
Mac OS 您需要安装旧 Java SE 6 运行环境才能打开“XXX” 问题问题描述:今天在Mac OS上安装一个app的时候提示 “您需要安装旧 Java SE 6 运行环境才能打开 XXX” ,在网上搜索了一下,有说要改app的info.plist文件的,将其中的JVMVersion改成自己机器上的版本的,但是在我的环境下修改了仍然不起作用,最后还是使用了下面的方法搞定的。解决办法从下面的链
【Mac】Mac 您需要安装旧 Java SE 6 运行环境才能打开"idea/pycharm"
有两种解决办法: 1、下载:适用于 OS X 的 Java 2014-001 ,安装即可解决。 2、用文本编辑器打开/Applications/IntelliJ IDEA 13.app/Contents/Info.plist 搜索JVMVersion,将其值改为1.7* 再次运行应用即可看到应用成功运行