2 u010844976 u010844976 于 2014.09.11 11:03 提问

android 如何使用imageIO类呢 引用jar包编译没错 运行就报错了 说找不到

部分代码
public static String getImagePixel(Bitmap bt) {
setBitmap(bt);
int R=0;
int G=0;
int B=0;
List list=new ArrayList();
File files = new File("/mnt/sdcard/inncloudimage/req_images/Image.jpg");
BufferedImage bi = null;
try {
bi = ImageIO.read(files);
} catch (Exception e) {
e.printStackTrace();
}
int width = bi.getWidth();
int height = bi.getHeight();
int sum=width*height;
int minx = bi.getMinX();
int miny = bi.getMinY();
for (int i = minx; i < width; i++) {
for (int j = miny; j < height; j++) {
int pixel = bi.getRGB(i, j);
R=(pixel & 0xff0000) >> 16;
G=(pixel & 0xff00) >> 8;
B=(pixel & 0xff);
list.add(R+"-"+G+"-"+B);
}
}
return getMaxCount(list);
}

ImageIO.read(files);要用到这个获取jpg的颜色 android好像不能用啊 安卓有没有提供什么呢

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Maven项目加入jar包能编译,运行时报错找不到jar包的类
Maven项目加入jar包能编译,运行时报错找不到jar包的类背景介绍 正在做一个基于SSM用mave管理依赖的项目,其中需要java-1.0.2.jar的MultimediaInfo类和Encoder类,先前再pom中没有写找个包的依赖,遂直接将包加在了Build Path下。能正常编译,当运行的时候就报错,找不到类。 报错如下:java.lang.ClassNotFoundException
android项目导入外部jar包后不报错但运行时报找不到类的问题
解决办法: 一、 在项目右键--> Build Path --> Configure Build Path --> 在Libraries tab中 点击右边的Add Library --> User Libraries --> New --> 输入你的Library名字,确定 --> Add Jars --> 添加你的jar包。 完成这一步之后,项目中就不会报错的了,但是一运行,就会报找
关于为什么jar包放入classpath为什么启动tomcat还报找不到类的错误
正确的路径是WEB-INF/lib,否则进不了tomcat容器。
android已经导入jar包后运行找不到相关类
android已经导入jar包后运行找不到相关类 http://blog.csdn.net/liushaogeng/article/details/6641704   若出现这个错误 java.lang.IllegalArgumentException: already added: Lorg/apache/commons/httpclient/AutoCloseInputStream;
明明jar包已经引入了,并且编译不报错,但是运行却还提示classnotfound,什么原因?
我在写cxf的客户端代码调用cxf接口的时候,编译不报错,但是运行这一句的时候的时候报错: Client client = clientFactory.createClient("http://XX.XX.XX.XX:8080/XX/XXService?wsdl"); 报错提示: Caused by: java.lang.ClassNotFoundException: com.sun.t
eclipse集成tomcat运行web时提示引入jar包的类找不到的解决办法
在eclipse集成tomcat开发web时,java类引入的jar包,编译通过,但启动tomcat运行web时提示找不到jar包内的类,需要作如下配置,将jar包在部署到集成的tomcat环境中。 问题:在 web应用 右键->Run as -> Run on Server情况下,会找不到Java Resources下Libraries的jar,应该是eclipse工程在发布到tomc
解决eclipse中找不到jar包问题
当使用eclipse导入外部的web工程时,有时会提示HttpServletRequest, ServletActionContext找不到的情况,解决办法: (注:我已经引用了struts2的jar包,classpath有,但eclipse就不认识,提示我去配buildpath,很怪异)  选中项目–>properties–>Targeted Runtimes–>在右边窗口中选择你使用的服务
Eclipse 引用外部library工程,运行时报NoClassDefFoundError的解决
好久没有碰过Eclipse了,公司这边现在在用这个做开发。 在将工程作为library引用至项目的过程中,运行时报错NoClassDefFoundError。 假设我现在是MultiDexApplication工程要引用AndFixLib工程 网上大部分说的操作是: 这么添加,并且 这里要勾选一下。 而实际中测试,Order and Export 勾选不勾选,引用了An
引入第三方jar包编译正常,运行报错的问题解决方法
原文地址:点击打开链接 网上下载的一些程序,如果导入了第三方jar包的,在本机上运行总是会报class not found 异常. 下面是解决方法: 1.首先要导入这个包,这个大家都会了. 右击项目,选择build path,然后在library里将第三方jar包添加进去就ok了.   2.接下来是很重要的一步.eclipse中右击你的放jar文件的lib/
maven dependencies已经引入了相应jar包,java编译的时候依然找不到类
出现一个奇怪的问题就是,Maven的dependencies已经引入了相应的jar包,但是在java文件中依然出现找不到某些类的编译错误,我在maven引入的jar包中确实是可以找到对应的类的,做了很多尝试,比如clean project,比如maven update project,比如删掉项目重新引入,比如删掉编译错误的类对应的jar的maven仓库中文件重新下载,依然解决不了这个问题,最后解...