Android Studio找不到FragmentActivity类

FragmentActivity类是在android.support.v4中的,但是我没办法import到程序中,根据网上的说明要导入jar包,但是我发现在Android Studio\sdk\extras\android\support\v4中已经存在了,为什么还是无法使用,这个类到底如何使用

4个回答

我的电脑是苹果的,我是这样的解决,你看看能不能有用。
右击项目——》open module settings——》选择第五个选项卡“Dependencies”——》点击加号——》选择第一个Library dependency
——》我选择的V4的版本是“com.android.support:support-v4:23.0.2”——》导入后使用快捷键alt+enter即可。
如果还是无法导入,就是SDK更新的问题。

我也遇到这个问题,不知楼主有没有解决,如果解决了请告知一下解决方法。^_^

u014737660
0Firmament0 这个类在现在的API中已经废弃了,不推荐使用,直接用Fragment实现
5 年多之前 回复

找到android.support.v4的包,添加到libs文件夹中,点击这个文件包,右键,设置为Library就行了

u012131702
欧拉啊旺 回复u012131702: 旧版本的好像很难,现在版本的,按alt+enter就行了……真心无力
5 年多之前 回复
u012131702
欧拉啊旺 看错题目,对不起,这个………………好像点击工程填充什么的,等我研究一下
5 年多之前 回复

同问!解决的话麻烦请告知一声,小弟在这里多谢了......

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐