Bumblebee only successful one time on kernel 4.0.0-rc1

I am running on an ArchLinux 64 bit system on the newly released kernel 4.0.0-rc1 and the proprietary nvidia driver. I have not enabled any testing repositories and have built both the bbswitch and nvidia kernel modules from the AUR using their respecitve "dkms" labeled builds, and am using the bumblebee binary from the official repositories. The dkms modules both compiled file, and even successfully run the first time that a command is invoked:

optirun glxgears

After stopping the command with Ctrl+C, attempting to run the same command again displays an error log:

[  404.919521] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  404.920061] [DEBUG]optirun version 3.2.1 starting...
[  404.920094] [DEBUG]Active configuration:
[  404.920103] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  404.920112] [DEBUG] X display: :8
[  404.920121] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia
[  404.920130] [DEBUG] Socket path: /var/run/bumblebee.socket
[  404.920138] [DEBUG] Accel/display bridge: primus
[  404.920147] [DEBUG] VGL Compression: proxy
[  404.920155] [DEBUG] VGLrun extra options: 
[  404.920164] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[  405.425518] [INFO]Response: No - error: Could not load GPU driver

[  405.425578] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  405.425595] [DEBUG]Socket closed.
[  405.425643] [ERROR]Aborting because fallback start is disabled.
[  405.425674] [DEBUG]Killing all remaining processes.

Bumblebee fails and leaves the dedicated nvidia graphics on as a result.

Bumblebee worked perfectly fine on kernel 3.19.1, no changes were made to any nvidia or bbswitch files inbetween kernel upgrades, aside from a small patch which was needed to get the nvidia module to run and can be found here:


I do not know if the patch suggested from the link above has affected anything having to do with the nvidia driver, but without the change, the nvidia module would not build on the new kernel 4.0.

I am able to restart the bumblebeed.service using systemctl and this successfully turns off the dedicated nvidia graphics, however attempting to run the optirun command from above once again fails with the same GPU error. I cannot really say if this is an issue with the nvidia code or bumblebee itself, but figured I would leave this in order to make the devs aware.


2020/11/27 02:54
  • 点赞
  • 收藏
  • 回答