dzc372787439
Carry_小超
2015-01-20 06:30
采纳率: 100%
浏览 1.8k

关于windows 7 64位 pomelo的安装 求大神解救

最近想研究下Node.js 在安装pomelo的时候 总是报错 求大神些帮忙解决下 怎样才能成功搭建node.js和pomelo
谢谢大家。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • 91program
    91program 2015-01-20 06:39
    已采纳

    pomelo是基于Node.js的,目前pomelo已经完全支持Windows、Linux、Mac等多种平台。Win8 都可以安装了,Win7 还有问题吗?

    准备
    确保你的机器可以上网,因为安装pomelo的过程需要从网上下载其依赖的包。

    确保你的系统上已经要安装了Node,目前最新的Node提供了已经编译好的二进制安装包,包括Windows,Mac和Linux等平台。想省事的话,直接去这里下载对应的安装包,直接安装就好了。Node同时也提供了传统的从源码编译的方式安装,不过比起直接使用二进制的方式要麻烦。

    确保你的系统中安装有python(2.5 < version < 3.0)以及C++的编译器。Node的源码主要由C++代码和JavaScript代码构成,但是却用gyp工具来做源码的项目管理,该工具采用Python语言写成的。对于非windows平台,一般都会预装Python以及C++编译工具;对于Windows系统,请确保你的Windows系统包含源码编译工具。在Windows平台上,Node.js采用gyp来生成Visual Studio Solution文件,最终通过VC++的编译器将其编译为二进制文件。

    虽然pomelo是用Javascript写成,但是pomelo依赖的库中,有使用了C++语言写的扩展,因此安装pomelo的过程中会使用到C++编译器。 所以,在安装之前请确保你的Windows系统满足以下两个条件:

    python(2.5<version<3.0)。
    VC++ 编译器,包含在Visual Studio 2010中(VC++ 2010 Express亦可)。对于windows8的用户,需要安装Microsoft Visual Studio C++ 2012。
    如果你使用的是Mac OS X系统, 则需要安装Xcode Command Line Tools或者Xcode的完整包以及make工具.

    点赞 评论
  • q107770540
    兔子党-督察 2015-01-20 06:31

    你至少说明一下报什么错

    点赞 评论
  • dzc372787439
    Carry_小超 2015-01-20 06:37

    图片说明
    图片说明
    图片说明
    图片说明

    帮忙看下 谢谢

    点赞 评论
  • oyljerry
    oyljerry 2015-01-20 06:55

    需要安装代码要求对应的VC编译器版本

    点赞 评论

相关推荐