使用Myclipse生成webservice客户端,报错

使用Myclipse生成webservice客户端,import javax.xml.bind.annotation.XmlSeeAlso;报错,是少包吗?,少了哪个 包。环境:jdk1.5 (跟这个有关吗)

2个回答

一般来说不存在少包的问题,按Ctrl+Shift+o会自动导入你代码所需要的包,当然,第三方包不算,这需要手动导入

u010078032
xuanfeng6060 Xfire版本太低了,不支持@xmlseealso,如何升级才不会影响到其他接口?
大约 5 年之前 回复

你需要把报的错误详细说一下,你这样太笼统了

u010078032
xuanfeng6060 因为之前接口都是用xfire1.2,问要如何升级不影响其他接口,xfire有更高的版本吗?
大约 5 年之前 回复
u010078032
xuanfeng6060 就是注解@xmlseealso报错,是jaxb-api-2.0家jar包中不支持,2.1中才有,工具用xfire1.2,如何直接替换掉那个包有影响吗?
大约 5 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问