u010411264
_竹子_
采纳率0%
2015-02-04 04:25 阅读 3.6k

java.lang.UnsupportedClassVersionError

10

04-Feb-2015 12:16:45.308 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log ContextListener: contextInitialized()
04-Feb-2015 12:16:45.308 INFO [localhost-startStop-1] org.apache.catalina.core.ApplicationContext.log SessionListener: contextInitialized()
04-Feb-2015 12:16:47.345 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.filterStart Exception starting filter struts2
java.lang.UnsupportedClassVersionError: org/crazyit/app/action/LoginAction : Unsupported major.minor version 52.0 (unable to load class org.crazyit.app.action.LoginAction)http://ask.csdn.net/my#
at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2483)
at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:880)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1294)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1177)
at com.opensymphony.xwork2.util.ClassLoaderUtil.loadClass(ClassLoaderUtil.java:144)
at com.opensymphony.xwork2.ObjectFactory.getClassInstance(ObjectFactory.java:128)
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.verifyAction(XmlConfigurationProvider.java:472)
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addAction(XmlConfigurationProvider.java:426)
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addPackage(XmlConfigurationProvider.java:552)
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadPackages(XmlConfigurationProvider.java:292)
at org.apache.struts2.config.StrutsXmlConfigurationProvider.loadPackages(StrutsXmlConfigurationProvider.java:112)
at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:258)
at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:445)
at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:489)
at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:57)
at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)
at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)
at org.apache.catalina.core.ApplicationFilterConfig.(ApplicationFilterConfig.java:105)
at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4603)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5210)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:724)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:700)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:714)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1071)
at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1722)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
为什么是版本错误呢?我用的是jdk1.7.0_71,用的编译集成环境是 netbeans IDE 8.0.1 难道我要把jdk 给为jdk8不成。。。弄了好久了

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

3条回答 默认 最新

  • eagleyan Coursera 2015-02-04 23:00

    netbeans IDE 8.0.1的缺省配置是source/binary format是JDK8,有可能你安装netbeans IDE 8.0.1的时候你机器上已经有一个jdk8,后来你卸载掉了

    点赞 1 评论 复制链接分享
  • liSqiang liSqiang 2015-02-04 07:13

    JDK版本过低。。。。

    点赞 评论 复制链接分享
  • u010411264 _竹子_ 2015-02-04 07:33

    问题解决了,我是这么做的。
    1.我把jdk卸载,然后重装(重装和原来的一样,也是jdk1.7.0_71),结果是:还是报错
    2.我把 netbeans IDE 8.0.1 卸载重装,然后就好了。

    我觉得问题应该归结于 netbeans IDE 8.0.1的编译配置参数吧!
    可能是因为netbeans IDE 8.0.1在编译的时候和执行的时候不相对应吧,反正问题就这样解决了。
    我不明白的是:我电脑只安装一种版本的jdk啊?如果是我在工程中用的特性是当前jdk版本不支持的,那么应该是jdk的问题啊,
    怎么就重装一下netbeans IDE 8.0.1就好了呢?还是说明是netbeans IDE 8.0.1环境参数问题。应该是这样的。。。

    网上很多热心好友都说,属于版本的问题,这也并不排除。

    以上测试保持不变的参数:
    1.工程使用的jdk版本是:jdk7
    2.工程编码是utf-8
    3.我使用的的jdk是:jdk1.7.0_71
    4.我的电脑只做一个版本的jdk

    点赞 评论 复制链接分享

相关推荐