python2.7安装sklearn报错:ImportError: DLL load failed

import sklearn
报错:
Traceback (most recent call last):
File "", line 1, in
import sklearn
File "D:\Python27\lib\site-packages\scikit_learn-0.15.2-py2.7-win-amd64.egg\sklearn__init__.py", line 38, in
from .base import clone
File "D:\Python27\lib\site-packages\scikit_learn-0.15.2-py2.7-win-amd64.egg\sklearn\base.py", line 10, in
from scipy import sparse
File "D:\Python27\lib\site-packages\scipy\sparse__init__.py", line 182, in
from .csr import *
File "D:\Python27\lib\site-packages\scipy\sparse\csr.py", line 15, in
from .sparsetools import csr_tocsc, csr_tobsr, csr_count_blocks, \
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools__init__.py", line 5, in
from .csr import *
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools\csr.py", line 26, in
_csr = swig_import_helper()
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools\csr.py", line 22, in swig_import_helper
_mod = imp.load_module('_csr', fp, pathname, description)
ImportError: DLL load failed: %1 不是有效的 Win32 应用程序。

用的python2.7.9,我已经安装了numpy1.9.1,scipy0.12.0,sklearn0.15.1,这些都是支持64位系统的,遇到这个问题我该怎么办

2个回答

看各个库官方是否支持Windows 64位os。有库dll加载不起来。

oyljerry
oyljerry 回复檐前潜心学种瓜: 也可能库对win64支持不够好
大约 5 年之前 回复
ljp7759325
檐前潜心学种瓜 不太懂os,但是从网上搜集了一些资料大多是讲需要所有模块都是支持64位的版本才行,看了看没有什么问题,主要是scipy.sparse这个类在加载的时候会报错,低版本的0.12.0和高版本的0.15.0都试过了,还是在这个地方报错,无奈了
大约 5 年之前 回复

不太懂os,但是从网上搜集了一些资料大多是讲需要所有模块都是支持64位的版本才行,看了看没有什么问题,主要是scipy.sparse这个类在加载的时候会报错,低版本的0.12.0和高版本的0.15.0都试过了,还是在这个地方报错,无奈了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Python3.7+Pyside2 运行exe文件提示“ImportError: DLL load failed: 找不到指定的程序。
# Python3.7+Pyside2 运行exe文件提示“ImportError: DLL load failed: 找不到指定的程序 1.问题描述 a.python 3.7 + pyside2 (只用pyside2,没有使用PyQt5) b.使用pyinstaller -F xxx.py 打包,生成xxx.exe c.使用cmd运行exe文件 2.报错 Traceback (most recent call last): File "PyInstaller\loader\rthooks\pyi_rth_qt5plugins.py", line 47, in <module> ModuleNotFoundError: No module named 'PyQt5' During handling of the above exception, another exception occurred: Traceback (most recent call last): File "PyInstaller\loader\rthooks\pyi_rth_qt5plugins.py", line 49, in <module> ImportError: DLL load failed: 找不到指定的程序。 [16072] Failed to execute script pyi_rth_qt5plugins 不知道为啥提示No module named 'PyQt5',在安装的lib中也只有pyside2; 多谢大神指点。 20190730,更新: 经过多次尝试和修改,发现lib库的安装的问题。代码中没有调用QT5的,在lib安装的时候,如果是使用pycharm setting中安装,安装的路径是在项目的文件夹,如果使用python的终端命令pip进行安装,安装在python的lib目录下,两个路径有时候不能完全的调用。 后来重新都是统一使用python 终端 pip命令安装,问题解决。
运行scrapy项目报错:ImportError:DLL load failed:操作系统无法运行
![图片说明](https://img-ask.csdn.net/upload/201801/16/1516088805_718484.png) 前几天还一直正常,后来不知怎么就出现这个错误,产生的原因是什么,我该如何解决呢? Python版本是:Anaconda3
tensorflow报错:ImportError:No module named 'tensorflow.python.platform'?
今天要打开tensorboard的时候出现报错: ![图片说明](https://img-ask.csdn.net/upload/201906/02/1559476838_499887.png) 然后试着用python import tensorflow as tf 检查了一下,还是同样的报错。 所有用到import TensorFlow的程序都无法运行了。 用网上的方法,添加PATH或者给tensorflow升级、重新安装后都是这样,不知道是为啥。
执行python manage.py migrate命令有问题
我在windows系统搭建了开发环境,使用的是pytohn2.7版本,在本地开发环境验证测试,执行python manage.py migrate命令有问题: 我在这个位置执行的命令: ![图片说明](https://img-ask.csdn.net/upload/201912/16/1576467780_425609.png) 报错如下: ![图片说明](https://img-ask.csdn.net/upload/201912/16/1576467889_633346.png) D:\python2.7\python2.7\Lib\site-packages\django\conf\project_template>python manage.py migrate Traceback (most recent call last): File "manage.py", line 10, in <module> execute_from_command_line(sys.argv) File "D:\python2.7\python2.7\lib\site-packages\django\core\management\__init__.py", line 338, in execute_from_command_line utility.execute() File "D:\python2.7\python2.7\lib\site-packages\django\core\management\__init__.py", line 303, in execute settings.INSTALLED_APPS File "D:\python2.7\python2.7\lib\site-packages\django\conf\__init__.py", line 48, in __getattr__ self._setup(name) File "D:\python2.7\python2.7\lib\site-packages\django\conf\__init__.py", line 44, in _setup self._wrapped = Settings(settings_module) File "D:\python2.7\python2.7\lib\site-packages\django\conf\__init__.py", line 92, in __init__ mod = importlib.import_module(self.SETTINGS_MODULE) File "D:\python2.7\python2.7\lib\importlib\__init__.py", line 37, in import_module __import__(name) ImportError: No module named {{ project_name }}.settings 求大神指教,是我执行的目录位置有问题吗?
python2.7导入goose包失败
安装goose包时失败,报如下错: File "F:\python2.7.13\lib\site-packages\goose\__init__.py", line 26, in <module> from goose.crawler import CrawlCandidate File "F:\python2.7.13\lib\site-packages\goose\crawler.py", line 28, in <module> from goose.extractors import StandardContentExtractor ImportError: cannot import name StandardContentExtractor 请问要怎么解决?
monkeyrunner下跑Python3.6的代码老报错:no module named:com
最近在用Python 进行 Android 的自动化测试,Python 3.0之前可以通过 from com.android.monkeyrunner import MonkeyRunner 导入MonkryRunner方法的,但是在Python 3.6 中使用这种方法失败了,提示如下: Traceback (most recent call last): File "<pyshell#0>", line 1, in <module> from com.android.monkeyrunner import MonkeyRunner ImportError: No module named 'com'
python2.7安装keras时报错,什么原因呢?
安装Keras时出错,np__utils是什么模块? ``` Traceback (most recent call last): File "<pyshell#28>", line 1, in <module> import keras File "C:\Python27\lib\site-packages\keras\__init__.py", line 3, in <module> from . import utils File "C:\Python27\lib\site-packages\keras\utils\__init__.py", line 2, in <module> from . import np_utils ImportError: cannot import name np_utils ```
Python2.7.9安装setuptools-0.6c11出错
running install ERROR:root:code for hash md5 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type md5 ERROR:root:code for hash sha1 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type sha1 ERROR:root:code for hash sha224 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type sha224 ERROR:root:code for hash sha256 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type sha256 ERROR:root:code for hash sha384 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type sha384 ERROR:root:code for hash sha512 was not found. Traceback (most recent call last): File "/usr/local/lib/python2.7/hashlib.py", line 147, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor raise ValueError('unsupported hash type ' + name) ValueError: unsupported hash type sha512 Traceback (most recent call last): File "setup.py", line 94, in <module> scripts = scripts, File "/usr/local/lib/python2.7/distutils/core.py", line 151, in setup dist.run_commands() File "/usr/local/lib/python2.7/distutils/dist.py", line 953, in run_commands self.run_command(cmd) File "/usr/local/lib/python2.7/distutils/dist.py", line 972, in run_command cmd_obj.run() File "/setuptools-0.6c11/setuptools/command/install.py", line 76, in run self.do_egg_install() File "/setuptools-0.6c11/setuptools/command/install.py", line 85, in do_egg_install easy_install = self.distribution.get_command_class('easy_install') File "/setuptools-0.6c11/setuptools/dist.py", line 395, in get_command_class self.cmdclass[command] = cmdclass = ep.load() File "/setuptools-0.6c11/pkg_resources.py", line 1954, in load entry = __import__(self.module_name, globals(),globals(), ['__name__']) File "/setuptools-0.6c11/setuptools/command/easy_install.py", line 21, in <module> from setuptools.package_index import PackageIndex, parse_bdist_wininst File "/setuptools-0.6c11/setuptools/package_index.py", line 10, in <module> from md5 import md5 File "/usr/local/lib/python2.7/md5.py", line 10, in <module> from hashlib import md5 ImportError: cannot import name md5 以上是问题呈现。
在学习python flask migrate中,当在CMD中输入 python manager.py db migrate的时候,显示ImportError:DLL load failed,这个怎么解决?
在学习python flask的时候,我想进行数据迁移。 但当我初始化后, 继续在cmd里输入python manager.py db migrate的时候,系统提示说 **ImportError: DLL load failed: The specified module could not be found.** 不知道是哪里出了问题,小白一枚,求大神们帮帮忙。 下面的是我manager.py 的代码: ``` from flask_script import Manager from flaks_migrate import app from flask_migrate import Migrate,MigrateCommand from extension import db from models import Article manager = Manager(app) migrate = Migrate(app,db) manager.add_command('db',MigrateCommand) if __name__ == '__main__': manager.run() ```
seaborn,'ImportError: DLL load failed: 找不到指定的模块'
pip安装成功 ``` C:\Users\Administrator>pip install seaborn-0.7.0-py2.py3-none-any.whl Processing c:\users\administrator\seaborn-0.7.0-py2.py3-none-any.whl Installing collected packages: seaborn Successfully installed seaborn-0.7.0 ``` 导入包时,报错 ``` C:\Users\Administrator>python Python 2.7.11 (v2.7.11:6d1b6a68f775, Dec 5 2015, 20:32:19) [MSC v.1500 32 bit ( Intel)] on win32 Type "help", "copyright", "credits" or "license" for more information. >>> import seaborn Traceback (most recent call last): File "<stdin>", line 1, in <module> File "D:\Python27\lib\site-packages\seaborn\__init__.py", line 1, in <module> from .rcmod import * File "D:\Python27\lib\site-packages\seaborn\rcmod.py", line 8, in <module> from . import palettes File "D:\Python27\lib\site-packages\seaborn\palettes.py", line 12, in <module> from .utils import desaturate, set_hls_values, get_color_cycle File "D:\Python27\lib\site-packages\seaborn\utils.py", line 8, in <module> from scipy import stats File "D:\Python27\lib\site-packages\scipy\stats\__init__.py", line 338, in <mo dule> from .stats import * File "D:\Python27\lib\site-packages\scipy\stats\stats.py", line 180, in <modul e> import scipy.special as special File "D:\Python27\lib\site-packages\scipy\special\__init__.py", line 627, in < module> from ._ufuncs import * ImportError: DLL load failed: 找不到指定的模块。 >>> ``` python版本2.7 我的系统是win7系统 64位 ![图片说明](https://img-ask.csdn.net/upload/201604/15/1460714570_426118.png)
使用celery执行celery -A tasks worker --loglevel=info后报错from kombu.matcher import match,ImportError: No module named 'kombu.matcher'
shell中报错如下 ``` File "/usr/local/lib/python3.5/dist-packages/celery/utils/imports.py", line 55, in instantiate return symbol_by_name(name)(*args, **kwargs) File "/home/tarena/.local/lib/python3.5/site-packages/kombu/utils/imports.py", line 56, in symbol_by_name module = imp(module_name, package=package, **kwargs) File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) File "<frozen importlib._bootstrap>", line 986, in _gcd_import File "<frozen importlib._bootstrap>", line 969, in _find_and_load File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked File "<frozen importlib._bootstrap>", line 673, in _load_unlocked File "<frozen importlib._bootstrap_external>", line 665, in exec_module File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed File "/usr/local/lib/python3.5/dist-packages/celery/app/control.py", line 12, in <module> from kombu.matcher import match ImportError: No module named 'kombu.matcher' ``` celery提不起来,求哪位大神赐教
问linux中运行cx_oracle出现下面的错误ImportError: libclntsh.so.11.1: wrong ELF class: ELFCLASS32
我想问linux中运行cx_oracle就出现I下面的错误,我应该怎么1解决呢·? 如果解决不了,我想把python2.6.6升级到python2.7会出现什么问题吗? ![图片说明](https://img-ask.csdn.net/upload/201903/10/1552204603_255184.png)
python3.5中安装PIL包,显示成功,但是导入的时候报错 ImportError
我是windows64位的系统,在网上找到了支持python3.x的PIL包,在命令行里使用pip命令安装,显示successfully成功,但是编写文件的时候from PIL import Image出现错误,ImportError:DLL load failed: 找不到指定的模块。网上搜了下,好像是动态链接库目录的问题,具体怎么回事我也不清楚,也不知道去哪找.dll文件,哪位大神帮忙解答一下 ,万分感谢! python3.x的64位系统的PIL网址:http://www.lfd.uci.edu/~gohlke/pythonlibs/#pil 对了,我下载的是Pillow-3.0.0-cp35-none-win_amd64.whl这个包
Python全局环境下sklearn包中缺失Imputer函数
系统win10 64位,python版本3.7.4。 全局环境下,在我输入下载sklearn包的代码后,显示结果如下,包已经安装: ``` pip install sklearn Requirement already satisfied: sklearn in e:\python\lib\site-packages (0.0) Requirement already satisfied: scikit-learn in e:\python\lib\site-packages (from sklearn) (0.22) Requirement already satisfied: numpy>=1.11.0 in e:\python\lib\site-packages (from scikit-learn->sklearn) (1.17.4) Requirement already satisfied: scipy>=0.17.0 in e:\python\lib\site-packages (from scikit-learn->sklearn) (1.3.3) Requirement already satisfied: joblib>=0.11 in e:\python\lib\site-packages (from scikit-learn->sklearn) (0.14.1) ``` 然而在使用sklearn中的Imputer函数时,会出现报错: ``` >>> import numpy as np >>> import sklearn >>> from sklearn import preprocessing >>> from sklearn.preprocessing import Imputer Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: cannot import name 'Imputer' from 'sklearn.preprocessing' (E:\python\lib\site-packages\sklearn\preprocessing\__init__.py) ``` 利用dir()查看包内的函数,发现没有Imputer: ``` >>> dir(sklearn.preprocessing) ['Binarizer', 'FunctionTransformer', 'KBinsDiscretizer', 'KernelCenterer', 'LabelBinarizer', 'LabelEncoder', 'MaxAbsScaler', 'MinMaxScaler', 'MultiLabelBinarizer', 'Normalizer', 'OneHotEncoder', 'OrdinalEncoder', 'PolynomialFeatures', 'PowerTransformer', 'QuantileTransformer', 'RobustScaler', 'StandardScaler', '__all__', '__builtins__', '__cached__', '__doc__', '__file__', '__loader__', '__name__', '__package__', '__path__', '__spec__', '_csr_polynomial_expansion', '_data', '_discretization', '_encoders', '_function_transformer', '_label', 'add_dummy_feature', 'binarize', 'label_binarize', 'maxabs_scale', 'minmax_scale', 'normalize', 'power_transform', 'quantile_transform', 'robust_scale', 'scale'] ``` 但是在conda的base环境下,陆续安装numpy、scipy、matplotlib后,安装 scikit-learn包,就可以使用这个函数了。 我寻找了很久的解决方案,网上说的路径和Imputer相同的情况没有发生,请问大佬们这究竟是怎么回事儿啊
cmd环境下运行python,导入pandas包,报错ImportError:C extension:
请教下,安装python后,环境变量也设置好了。用pip命令安装pandas和numpy 也都成功了。 但是在cmd环境下运行python命令,导入pandas包的时候,却报错: ImportError:C extension: No module named 'pandas._libs.tslibs.nattype' not built 重新用pip命令卸载了pandas,重装了下。。仍旧报错:(这次名称换成了conversion) ImportError:C extension: No module named 'pandas._libs.tslibs.conversion' not built 这个是什么原因? pandas版本0.24.2,numpy的版本1.16.3 ![图片说明](https://img-ask.csdn.net/upload/201905/15/1557901361_293706.png) ![图片说明](https://img-ask.csdn.net/upload/201905/15/1557901370_747149.png)
ImportError: No module named etree.ElementTree
import xml.etree.ElementTree as ET per=ET.parse('test.xml') lst_node = root.getiterator("video") for node in lst_node: print_node(node) 版本python2.7.3 居然报错:No module named etree.ElementTree 重装了2.7.9依然有错。。。菜鸟求大神
python引用问题:from wx.lib.pubsub import Publisher
在模块开始加入 from wx.lib.pubsub import Publisher 报错: Traceback (most recent call last): File "G:\learning\python\python_workspace\test_QQ\src\test\test2.py", line 15, in <module> from wx.lib.pubsub import Publisher ImportError: cannot import name Publisher 网上搜了好久,信息好少! 不知道怎么办,求大神指导!
已经安装了pymssql,但是import pymssql还是会报错
非常确定pymssql已经安装成功了,但是导入pymssql时还是提示找不到指定模块 E:\python_install>pip list pip (8.1.1) pymssql (2.1.2) selenium (2.52.0) setuptools (20.4) XlsxWriter (0.8.4) import pymssql ImportError: DLL load failed: 找不到指定的模块。
rllib.error.HTTPError: HTTP Error 403: Forbidden
python小白,下列代码出现urllib.error.HTTPError: HTTP Error 403: Forbidden,不知怎么解决,求各位大佬帮忙。 ``` """ Retrieve radar data from the NASA and plot a view of the Grand Canyon landscape. We cannot display the whole data, as it would be too big. To display more, see the canyon decimation example. This example is interesting as it shows how numpy can be used to load and crop data completly foreign to Mayavi. """ # Author: Gael Varoquaux <gael.varoquaux@normalesup.org> # Copyright (c) 2008, Enthought, Inc. # License: BSD Style. # Retrieve the grand Canyon topological data ################################## import os # Original file: #'ftp://e0srp01u.ecs.nasa.gov/srtm/version2/SRTM1/Region_04/N39E115.hgt.zip' if not os.path.exists('N39E115.hgt.zip'): # Download the data try: from urllib import urlopen except ImportError: from urllib.request import urlopen print('Downloading data, please wait (10M)') opener = urlopen( 'https://s3.amazonaws.com/storage.enthought.com/www/sample_data/N39E115.hgt.zip' ) open('N39E115.hgt.zip', 'wb').write(opener.read()) # Load the data (signed 2 byte integers, big endian) ########################## import zipfile import numpy as np data = np.fromstring(zipfile.ZipFile('N39E115.hgt.zip').read('N39E115.hgt'), '>i2') data.shape = (3601, 3601) data = data.astype(np.float32) # Plot an interesting section ################################################# from mayavi import mlab data = data[:1000, 900:1900] # Convert missing values into something more sensible. data[data == -32768] = data[data > 0].min() mlab.figure(size=(400, 320), bgcolor=(0.16, 0.28, 0.46)) mlab.surf(data, colormap='gist_earth', warp_scale=0.2, vmin=1200, vmax=1610) # The data takes a lot of memory, and the surf command has created a # copy. We free the inital memory. del data # A view of the canyon mlab.view(-5.9, 83, 570, [5.3, 20, 238]) mlab.show() ```
在中国程序员是青春饭吗?
今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...
我在支付宝花了1分钟,查到了女朋友的开房记录!
在大数据时代下,不管你做什么都会留下蛛丝马迹,只要学会把各种软件运用到极致,捉奸简直轻而易举。今天就来给大家分享一下,什么叫大数据抓出轨。据史料证明,马爸爸年轻时曾被...
程序员请照顾好自己,周末病魔差点一套带走我。
程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。
卸载 x 雷某度!GitHub 标星 1.5w+,从此我只用这款全能高速下载工具!
作者 | Rocky0429 来源 | Python空间 大家好,我是 Rocky0429,一个喜欢在网上收集各种资源的蒟蒻… 网上资源眼花缭乱,下载的方式也同样千奇百怪,比如 BT 下载,磁力链接,网盘资源等等等等,下个资源可真不容易,不一样的方式要用不同的下载软件,因此某比较有名的 x 雷和某度网盘成了我经常使用的工具。 作为一个没有钱的穷鬼,某度网盘几十 kb 的下载速度让我...
20道你必须要背会的微服务面试题,面试一定会被问到
写在前面: 在学习springcloud之前大家一定要先了解下,常见的面试题有那块,然后我们带着问题去学习这个微服务技术,那么就会更加理解springcloud技术。如果你已经学了springcloud,那么在准备面试的时候,一定要看看看这些面试题。 文章目录1、什么是微服务?2、微服务之间是如何通讯的?3、springcloud 与dubbo有哪些区别?4、请谈谈对SpringBoot 和S...
为什么猝死的都是程序员,基本上不见产品经理猝死呢?
相信大家时不时听到程序员猝死的消息,但是基本上听不到产品经理猝死的消息,这是为什么呢? 我们先百度搜一下:程序员猝死,出现将近700多万条搜索结果: 搜索一下:产品经理猝死,只有400万条的搜索结果,从搜索结果数量上来看,程序员猝死的搜索结果就比产品经理猝死的搜索结果高了一倍,而且从下图可以看到,首页里面的五条搜索结果,其实只有两条才是符合条件。 所以程序员猝死的概率真的比产品经理大,并不是错...
毕业5年,我问遍了身边的大佬,总结了他们的学习方法
我问了身边10个大佬,总结了他们的学习方法,原来成功都是有迹可循的。
推荐10个堪称神器的学习网站
每天都会收到很多读者的私信,问我:“二哥,有什么推荐的学习网站吗?最近很浮躁,手头的一些网站都看烦了,想看看二哥这里有什么新鲜货。” 今天一早做了个恶梦,梦到被老板辞退了。虽然说在我们公司,只有我辞退老板的份,没有老板辞退我这一说,但是还是被吓得 4 点多都起来了。(主要是因为我掌握着公司所有的核心源码,哈哈哈) 既然 4 点多起来,就得好好利用起来。于是我就挑选了 10 个堪称神器的学习网站,推...
这些软件太强了,Windows必装!尤其程序员!
Windows可谓是大多数人的生产力工具,集娱乐办公于一体,虽然在程序员这个群体中都说苹果是信仰,但是大部分不都是从Windows过来的,而且现在依然有很多的程序员用Windows。 所以,今天我就把我私藏的Windows必装的软件分享给大家,如果有一个你没有用过甚至没有听过,那你就赚了????,这可都是提升你幸福感的高效率生产力工具哦! 走起!???? NO、1 ScreenToGif 屏幕,摄像头和白板...
阿里面试,面试官没想到一个ArrayList,我都能跟他扯半小时
我是真的没想到,面试官会这样问我ArrayList。
曾经优秀的人,怎么就突然不优秀了。
职场上有很多辛酸事,很多合伙人出局的故事,很多技术骨干被裁员的故事。说来模板都类似,曾经是名校毕业,曾经是优秀员工,曾经被领导表扬,曾经业绩突出,然而突然有一天,因为种种原因,被裁员了,...
大学四年因为知道了这32个网站,我成了别人眼中的大神!
依稀记得,毕业那天,我们导员发给我毕业证的时候对我说“你可是咱们系的风云人物啊”,哎呀,别提当时多开心啦????,嗯,我们导员是所有导员中最帅的一个,真的???? 不过,导员说的是实话,很多人都叫我大神的,为啥,因为我知道这32个网站啊,你说强不强????,这次是绝对的干货,看好啦,走起来! PS:每个网站都是学计算机混互联网必须知道的,真的牛杯,我就不过多介绍了,大家自行探索,觉得没用的,尽管留言吐槽吧???? 社...
良心推荐,我珍藏的一些Chrome插件
上次搬家的时候,发了一个朋友圈,附带的照片中不小心暴露了自己的 Chrome 浏览器插件之多,于是就有小伙伴评论说分享一下我觉得还不错的浏览器插件。 我下面就把我日常工作和学习中经常用到的一些 Chrome 浏览器插件分享给大家,随便一个都能提高你的“生活品质”和工作效率。 Markdown Here Markdown Here 可以让你更愉快的写邮件,由于支持 Markdown 直接转电子邮...
看完这篇HTTP,跟面试官扯皮就没问题了
我是一名程序员,我的主要编程语言是 Java,我更是一名 Web 开发人员,所以我必须要了解 HTTP,所以本篇文章就来带你从 HTTP 入门到进阶,看完让你有一种恍然大悟、醍醐灌顶的感觉。 最初在有网络之前,我们的电脑都是单机的,单机系统是孤立的,我还记得 05 年前那会儿家里有个电脑,想打电脑游戏还得两个人在一个电脑上玩儿,及其不方便。我就想为什么家里人不让上网,我的同学 xxx 家里有网,每...
2020 年,大火的 Python 和 JavaScript 是否会被取而代之?
Python 和 JavaScript 是目前最火的两大编程语言,但是2020 年,什么编程语言将会取而代之呢? 作者 |Richard Kenneth Eng 译者 |明明如月,责编 | 郭芮 出品 | CSDN(ID:CSDNnews) 以下为译文: Python 和 JavaScript 是目前最火的两大编程语言。然而,他们不可能永远屹立不倒。最终,必将像其他编程语言一...
史上最全的IDEA快捷键总结
现在Idea成了主流开发工具,这篇博客对其使用的快捷键做了总结,希望对大家的开发工作有所帮助。
阿里程序员写了一个新手都写不出的低级bug,被骂惨了。
这种新手都不会范的错,居然被一个工作好几年的小伙子写出来,差点被当场开除了。
谁是华为扫地僧?
是的,华为也有扫地僧!2020年2月11-12日,“养在深闺人不知”的华为2012实验室扫地僧们,将在华为开发者大会2020(Cloud)上,和大家见面。到时,你可以和扫地僧们,吃一个洋...
AI 没让人类失业,搞 AI 的人先失业了
最近和几个 AI 领域的大佬闲聊 根据他们讲的消息和段子 改编出下面这个故事 如有雷同 都是巧合 1. 老王创业失败,被限制高消费 “这里写我跑路的消息实在太夸张了。” 王葱葱哼笑一下,把消息分享给群里。 阿杰也看了消息,笑了笑。在座几位也都笑了。 王葱葱是个有名的人物,21岁那年以全额奖学金进入 KMU 攻读人工智能博士,累计发表论文 40 余篇,个人技术博客更是成为深度学习领域内风向标。 ...
2020年,冯唐49岁:我给20、30岁IT职场年轻人的建议
点击“技术领导力”关注∆每天早上8:30推送 作者|Mr.K 编辑| Emma 来源|技术领导力(ID:jishulingdaoli) 前天的推文《冯唐:职场人35岁以后,方法论比经验重要》,收到了不少读者的反馈,觉得挺受启发。其实,冯唐写了不少关于职场方面的文章,都挺不错的。可惜大家只记住了“春风十里不如你”、“如何避免成为油腻腻的中年人”等不那么正经的文章。 本文整理了冯...
最全最强!世界大学计算机专业排名总结!
我正在参与CSDN200进20,希望得到您的支持,扫码续投票5次。感谢您! (为表示感谢,您投票后私信我,我把我总结的人工智能手推笔记和思维导图发送给您,感谢!) 目录 泰晤士高等教育世界大学排名 QS 世界大学排名 US News 世界大学排名 世界大学学术排名(Academic Ranking of World Universities) 泰晤士高等教育世界大学排名 中国共...
作为一名大学生,如何在B站上快乐的学习?
B站是个宝,谁用谁知道???? 作为一名大学生,你必须掌握的一项能力就是自学能力,很多看起来很牛X的人,你可以了解下,人家私底下一定是花大量的时间自学的,你可能会说,我也想学习啊,可是嘞,该学习啥嘞,不怕告诉你,互联网时代,最不缺的就是学习资源,最宝贵的是啥? 你可能会说是时间,不,不是时间,而是你的注意力,懂了吧! 那么,你说学习资源多,我咋不知道,那今天我就告诉你一个你必须知道的学习的地方,人称...
那些年,我们信了课本里的那些鬼话
教材永远都是有错误的,从小学到大学,我们不断的学习了很多错误知识。 斑羚飞渡 在我们学习的很多小学课文里,有很多是错误文章,或者说是假课文。像《斑羚飞渡》: 随着镰刀头羊的那声吼叫,整个斑羚群迅速分成两拨,老年斑羚为一拨,年轻斑羚为一拨。 就在这时,我看见,从那拨老斑羚里走出一只公斑羚来。公斑羚朝那拨年轻斑羚示意性地咩了一声,一只半大的斑羚应声走了出来。一老一少走到伤心崖,后退了几步,突...
使用 Python 和百度语音识别生成视频字幕
文章目录从视频中提取音频根据静音对音频分段使用百度语音识别获取 Access Token使用 Raw 数据进行合成生成字幕总结 从视频中提取音频 安装 moviepy pip install moviepy 相关代码: audio_file = work_path + '\\out.wav' video = VideoFileClip(video_file) video.audio.write_...
一个程序在计算机中是如何运行的?超级干货!!!
强烈声明:本文很干,请自备茶水!???? 开门见山,咱不说废话! 你有没有想过,你写的程序,是如何在计算机中运行的吗?比如我们搞Java的,肯定写过这段代码 public class HelloWorld { public static void main(String[] args) { System.out.println("Hello World!"); } ...
【蘑菇街技术部年会】程序员与女神共舞,鼻血再次没止住。(文末内推)
蘑菇街技术部的年会,别开生面,一样全是美女。
那个在阿里养猪的工程师,5年了……
简介: 在阿里,走过1825天,没有趴下,依旧斗志满满,被称为“五年陈”。他们会被授予一枚戒指,过程就叫做“授戒仪式”。今天,咱们听听阿里的那些“五年陈”们的故事。 下一个五年,猪圈见! 我就是那个在养猪场里敲代码的工程师,一年多前我和20位工程师去了四川的猪场,出发前总架构师慷慨激昂的说:同学们,中国的养猪产业将因为我们而改变。但到了猪场,发现根本不是那么回事:要个WIFI,没有;...
为什么程序猿都不愿意去外包?
分享外包的组织架构,盈利模式,亲身经历,以及根据一些外包朋友的反馈,写了这篇文章 ,希望对正在找工作的老铁有所帮助
Java校招入职华为,半年后我跑路了
何来 我,一个双非本科弟弟,有幸在 19 届的秋招中得到前东家华为(以下简称 hw)的赏识,当时秋招签订就业协议,说是入了某 java bg,之后一系列组织架构调整原因等等让人无法理解的神操作,最终毕业前夕,被通知调往其他 bg 做嵌入式开发(纯 C 语言)。 由于已至于校招末尾,之前拿到的其他 offer 又无法再收回,一时感到无力回天,只得默默接受。 毕业后,直接入职开始了嵌入式苦旅,由于从未...
世界上有哪些代码量很少,但很牛逼很经典的算法或项目案例?
点击上方蓝字设为星标下面开始今天的学习~今天分享四个代码量很少,但很牛逼很经典的算法或项目案例。1、no code 项目地址:https://github.com/kelseyhight...
立即提问