mac 编译Hadoop2.6出错

INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-project:pom:2.6.0
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: javax.servlet.jsp:jsp-api:jar -> duplicate declaration of version 2.1 @ line 563, column 19
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.apache.curator:curator-framework:jar -> duplicate declaration of version 2.6.0 @ line 915, column 18
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.apache.curator:curator-test:jar -> duplicate declaration of version 2.6.0 @ line 920, column 18
[WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-enforcer-plugin @ line 1154, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-project-dist:pom:2.6.0
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: javax.servlet.jsp:jsp-api:jar -> duplicate declaration of version 2.1 @ org.apache.hadoop:hadoop-project:2.6.0, /Users/xyj/App/hadoop-2.6.0-src/hadoop-project/pom.xml, line 563, column 19
[WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.apache.curator:curator-framework:jar -> duplicate declaration of version 2.6.0 @ org.apache.hadoop:hadoop-project:2.6.0, /Users/xyj/App/hadoop-2.6.0-src/hadoop-project/pom.xml, line 915, column 18

执行了mvn package -DskipTests -Pdist,native -Dtar报上面的错误。。求解

1个回答

遇到类错误,是不是JDK8? 我换回JDK7成功.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问