maconglingming
若明居者
采纳率100%
2015-04-28 01:15

双系统 Ubuntu 无法联网,ping不通网关

已采纳

这几天在win8的台式机上装了个Ubuntu 14.04双系统,64位的,但是在Ubuntu系统中怎么折腾也不能联网,照着网上各种说法配置都不行,路由器网关ping不通,报 Destination Host Unreachable,但ping本机地址正常,重启到windows系统也可以正常上网。
特来请教各位。下面详细说一下情况:


系统配置:Win8 + Ubuntu 14.04LTS 双系统64位UEFI启动,其中Ubuntu全新安装
网络环境:校园网,通过路由器 分配静态IP上网


填了下IP地址、网关和DNS什么的,就按照网上说的,修改/etc/network/interfaces:
本来里边只有一个环回地址,添加自己的静态IP设置:
auto eth0
iface eth0 inet static
address 192.168.1.8
netmask 255.255.255.0
gateway 192.168.1.1
在/etc/resolv.conf 也加入了DNS地址:
nameserver ......


相同的配置在windows下毫无问题,但在这个Ubuntu下就不行,测试ping的结果:
ping 127.0.0.1,正常
ping localhost,正常
ping 192.168.1.8(自己的IP),正常
ping 192.168.1.1(网关),报的信息如下:
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.8 icmp_seq=1 Destination Host Unreachable
From 192.168.1.8 icmp_seq=2 Destination Host Unreachable
...
完全不通。
ping 外网地址就更不行了。ping DNS地址同样报 Destination Host Unreachable
ping 192.168.1.7(局域网里另一台开着的电脑),也不通。
而且用局域网里另一台电脑看路由器的连接列表,根本没有我这个IP!其他机器上网都正常。


网线确定应该是插好的,因为重启后切换成windows就可以正常联网。。


期间N次更改auto eth0相关的设置,N次重启网络 /etc/init.d/networking restart
还有 ifdown/ifup eth0 也试过,重启系统也试过,都没有作用。


用ifconfig -a命令看过了,列出的貌似正常,一个eth0,其IP和网关就是我设的那个,但接收发送包数都是0:

ifconfig -a

eth0 Link encap:以太网 硬件地址 74:**:**:**:**:3f
inet 地址:192.168.1.8 广播:192.168.1.255 掩码:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)

lo Link encap:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 跃点数:1
接收数据包:138 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:138 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:10645 (10.6 KB) 发送字节:10645 (10.6 KB)
网卡MAC地址也没有错。


route -n 命令显示信息:
内核 IP 路由表
目标 网关 子网掩码 标志 跃点 引用 使用 接口
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0


不知道是不是网卡的问题,贴一下网卡型号:瑞昱 RTL8168/8111/8112 Gigabit Ethernet Controller,宏碁制造


实在不知道问题在哪儿了,路过的还请指点一下,感激不尽!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • baidu_31951969 baidu_31951969 6年前

    终于搞定了 原来现在的电脑在biso中就有有关网络链接的设置 我机子是dell optiplex 9020 原先遇到的问题就是一旦进行ubuntu与win系统的切换之后就不能上网了
    解决办法: 请检查你biso里有关网络(NIC)的设置 选择NIC: enable with Desktop Cloud 并制定静态ip OK

    点赞 6 评论 复制链接分享
  • baidu_31951969 baidu_31951969 6年前

    我遇到的是完全相同的情况 机子原装系统win7 我后来自己装了ubuntu 14.04 64bit 装的时候有那么几次不能自动获取地址
    (是在刚开始的时候填写你的地区信息) 但是反复的装 总有一次可以获取地址 也就是可以联网了(尼玛 机器会耍性子的 不得不说)
    然后故事就发生了 刚开始还好 系统可以自动找寻地址(DHCP)或者你也可以指定地址 然后你重启 再进入ubuntu 都可以上网 此时也能ping通网关
    尼玛 一旦我重启进入win7系统 好了 那从此以后在ubuntu上再也不能联网了 也ping不通网关 这什么情况

    点赞 评论 复制链接分享
  • maconglingming 若明居者 6年前

    楼主自己统一回复:发帖之后一直没有解决,最后重装了。重装之后,初次进入时网络连接会有一个默认连接,不管那个,直接用图形界面新建一个连接,就可以了。。参看上边回复,我的可能也与硬件或BIOS有关。现在的情况是这样的:双系统切换的时候会出问题,从windows重启到ubuntu时,要选重启而不是关机,这样ubuntu启动后再用图形界面重新选择自己建立的那个连接,就可以重新联网。否则不行。虽然我也不知道为什么。。but itworks...

    点赞 评论 复制链接分享
  • gamefinity 知常曰明 6年前

    在auto eth0后面一行,好像漏了一句 iface inet eth0 static吧

    点赞 评论 复制链接分享
  • xueluo0000 xueluo0000 6年前

    我遇到的是完全相同的问题,现在折腾死了,请问一下,你解决了吗?

    点赞 评论 复制链接分享
  • qichangleixin 是夜色太荒芜 6年前

    我也遇到了这个问题,最后问题解决了。但我不确定是哪一步:
    1)我以前配置过ssh免密码登陆,在/root/.ssh/known_hosts目录下有公钥,私钥的文件。我删除次文件rm -r /root/.ssh/known_hosts
    2)我etc下hosts文件里,我把hostname对应的Ip改成了静态ip,以前对应的不是此地址。
    乌班图能够联网了。但是用nm-tool命令还是获取不到网关,dns的信息。
    如果你已经解决了此问题。希望可以回复下。QQ:737546268

    点赞 评论 复制链接分享