在Linux下的Qt的编译错误解决?

我编译的的是deno里面的browser,自己拿出来单独编译的,总是出下面的错误

webview.cpp:53:31: error: QtUiTools/QUiLoader: No such file or directory
webview.cpp: In member function 'virtual QObject* WebPage::createPlugin(const QString&, const QUrl&, const QStringList&, const QStringList&)':
webview.cpp:133: error: 'QUiLoader' was not declared in this scope
webview.cpp:133: error: expected `;' before 'loader'
webview.cpp:134: error: 'loader' was not declared in this scope
webview.cpp: In member function 'void WebPage::handleUnsupportedContent(QNetworkReply*)':
webview.cpp:146: warning: unused variable 'isOpened'

2个回答

官方文档是否有说明如何编译安装。最好按官方的说明

编译环境肯定不正确,按照提示看看相关的文件是否存在

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐