weixin_39632293
weixin_39632293
2020-11-28 04:46

icons problem

Hi, OH 2.0.0 using start and no problem control, but icons do not appear on the web browser and mobile app. icons folder in "runtime/icons" icons

该提问来源于开源项目:openhab/openhab-addons

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

10条回答

  • weixin_39632293 weixin_39632293 5月前

    I wrote the above problems, it continues in the latest snapshot. I manually installing the icons folder (Openhab.ho to $ {} / conf / icons / classic) and great, icons web page looks and works fine. But the mobile application icons looks stable. Icons do not change according to the item status.

    image OpenHAB running tested on windows and raspberry pi2 java 1.7.0.79 and 1.8

    点赞 评论 复制链接分享
  • weixin_39850152 weixin_39850152 5月前

    I can confirm, I will have to investigate this in more depth. I assume that this might need a change in the mobile apps.

    点赞 评论 复制链接分享
  • weixin_39632293 weixin_39632293 5月前

    Latest snapshot not need manuel icons folder create. Direct seeing all icons. But icons not change of status on mobile application. When do you plan to change the mobile applications?

    点赞 评论 复制链接分享
  • weixin_39850152 weixin_39850152 5月前

    I have entered https://github.com/openhab/openhab.android/issues/145 and https://github.com/openhab/openhab.ios/issues/65

    If you are fluent in iOS or Android programming, feel free to provide a PR yourself!

    点赞 评论 复制链接分享
  • weixin_39850152 weixin_39850152 5月前

    The folder runtime/icons does not exist anymore. Are you sure you are using the latest snapshot?

    点赞 评论 复制链接分享
  • weixin_39632293 weixin_39632293 5月前

    Yes, I downloaded yesterday. Folder icons I added later.

    点赞 评论 复制链接分享
  • weixin_39850152 weixin_39850152 5月前

    So you mean you do not use the standard icons but have changed your sitemap to reference custom ones? Custom icons have to go into conf/icons/classic. Then they should be picked up correctly.

    点赞 评论 复制链接分享
  • weixin_39632293 weixin_39632293 5月前

    I had the same problem in the previous version are corrected so I waited. Yesterday I tried to download again, but the result is still the same. That's why I'm using alpha-2.

    点赞 评论 复制链接分享
  • weixin_39850152 weixin_39850152 5月前

    I have just checked again on the latest snapshot. All works well, if you put your custom icons in ${openhab.home}/conf/icons/classic.

    点赞 评论 复制链接分享
  • weixin_39632293 weixin_39632293 5月前

    Yes, it works. The web interface works fine. But the mobile application items icon do not change icon of status. Only constant.

    点赞 评论 复制链接分享

相关推荐