u010843886
以手筑城
2015-05-09 09:27
采纳率: 100%
浏览 13.0k
已采纳

tomcat在myeclipse里运行出现警告,求各位大神帮忙

警告: The APR based Apache Tomcat Native library failed to load. The error reported was [C:\apache-tomcat-7.0.61\bin\tcnative-1.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform]
java.lang.UnsatisfiedLinkError: C:\apache-tomcat-7.0.61\bin\tcnative-1.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform
不知道什么原因,重装系统后,系统由原来的32位变成现在的64位,但它提示的这错误是什么意思啊,摸不着头脑,求大神告知

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • u010843886
    以手筑城 2015-05-10 09:19
    已采纳

    图片说明
    在在cmd中输入:java -version,第三行内容是否包含“64”,怎么办

    点赞 评论
  • u013045631
    我染你黑白 2015-05-09 09:34

    打开cmd,并在cmd中输入:java -version

    查看第三行内容是否包含“64”,如果不包含,说明你设置的【JAVA_HOME】的地址指向的是32bit的JDK,那么你就需要下载一个64bit的JDK安装,并修改【JAVA_HOME】指向64bit的文件。

    如果设置完成上面之后还有问题,那么你就需要下载32-bit/64-bit集合体的Tomcat啦。

    地址:http://tomcat.apache.org/download-70.cgi

    选择:32-bit/64-bit Windows Service Installer (pgp, md5)

    安装这个Tomcat之后,OK。
    Can't load IA 64-bit .dll on a AMD 64-bit ..
    Can't load IA 64-bit .dll on a AMD 64-bit ..
    3

    以上2个步骤顺利完成,你的tomcat肯定再也不会出错啦!!!

    点赞 评论

相关推荐