centos6.5安装php5.5.25之后无法运行phpmyadmin

在编译php5.5.25时出现
configure: error: Don't know how to define struct flock on this system, set --enable-opcache=no
然后在网上找了解决方法
vi /etc/ld.so.conf # 编辑库文件
/usr/local/lib # 添加该行
:wq # 保存退出
ldconfig # 使之生效,更新动态库​

解决了php的问题之后安装phpMyAdmin-4.4.7-all-languages.tar.gz,但是在网页打开phpMyAdmin时一输入数据库的账号密码就马上退出程序(整个火狐浏览器都退出了)
初步估计是上面几行代码弄,但是具体原因就不知道了。
不知道有没有人遇到过?

3个回答

不要执行,换成下面的那条命令
错误,查找资料后,找到了解决方法
vi /etc/ld.so.conf # 编辑库文件
/usr/local/lib # 添加该行
:wq # 保存退出
ldconfig # 使之生效,更新动态库

执行下面一条命令就行了:【注意,下面这条语句仅对当前命令框有用】
export LD_LIBRARY_PATH=/lib/:/usr/lib/:/usr/local/lib

这个不影响 火狐浏览器吧~ 火狐浏览器的退出 和你的服务器配置没任何关系~

原来不只是PHPmyadmin,连magento也是不行,在安装magento时也会出现浏览器自动关闭的情况。
求各路大神帮帮忙。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问