android的 Error 'Theme.AppCompat.Light'问题

最近在打开别人的一个android源文件的时候出现了这个问题。
Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'.
在style.xml中有
<br> mainactivity中有<br> import android.support.v7.app.ActionBarActivity;然后<br> The import android.support.v7 cannot be resolved<br> 之前创建project是如果向下兼容到2.3也会弹出error,当时改成兼容到4.0就没问题了,网上查了是没有导入v7support包,后来在网上下载了,也import并且add lib了,之后这些哭的前面就成了红叉,Project下是问号,问题还是没有解决<br> 求问为什么?</p>

3个回答

楼主再发一下问题吧,这你发的图片都看不到。。。

是不是在gradle里进行了混淆 试下debug、
模式

编译的时候对于v7support部分请使用最高版本的安卓SDK进行编译,编译器会根据你的配置文件自行进行适配

duanymin
duanymin 回复Ycoronene: 类文件里的引用有修改么?
4 年多之前 回复
Ycoronene
Ycoronene 我试了下换了好多个编译的api,最高用了5.0.1,可是还是不行,快要搞疯掉了
4 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问