myeclipse6.5不支持自动拆箱装箱的问题

我用的myeclipse6.5,1.5的虚拟机,1.5的编译器,为啥不支持拆箱装箱。

3个回答

升级吧,到1.6 MyEclipse10 就好了、、、

Marvel_kc
Marvel_kc 好吧。
大约 5 年之前 回复

看下是否代码的问题或者jdk配置的是否正确,jdk1.5开始是支持拆箱装箱的,或者升级下jdk的版本看看。

Marvel_kc
Marvel_kc 我用的是myeclipse里面自带的编译环境,应该没问题吧?
大约 5 年之前 回复

编译器太老了,换成jdk1.7,myeclipse 10 就可以

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问