weixin_39646628
weixin_39646628
2020-11-28 13:51

Updated to 2.17.1, and get error

Description

after run yarn start,get this error:


Warning: Problem validating app.json: Unable to perform cache refresh for /Users/zhichou/.expo/cache/schema-32.0.0.json: XDLError: Invalid JSON returned from API: SyntaxError: Unexpected end of JSON input. Response body: .
Unable to read /Users/zhichou/.expo/cache/versions.json. SyntaxError: Unexpected token u in JSON at position 0
Error: Unable to read /Users/zhichou/.expo/cache/versions.json. SyntaxError: Unexpected token u in JSON at position 0
    at /xdl.7.1/src/tools/FsCache.js:101:15
    at Generator.next (<anonymous>)
    at step (/Users/zhichou/.config/yarn/global/node_modules/xdl/build/tools/FsCache.js:20:191)
    at /Users/zhichou/.config/yarn/global/node_modules/xdl/build/tools/FsCache.js:20:361
</anonymous>

and .expo/cache/versions.json file content:


undefined

Environment

MacOS: 10.14.4 node:v11.12.0 yarn:1.15.2 expo sdk :32.0.0

该提问来源于开源项目:expo/expo-cli

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

6条回答

为你推荐