2 csdn dchen csdn_dchen 于 2015.07.10 16:20 提问

maven 3.3 不能 兼容 jdk 1.6 ??

maven 3.3 不能 兼容 jdk 1.6 ??

貌似 jdk 1.8没事

4个回答

a747223454
a747223454   2015.07.10 16:25

Maven 3.3 requires JDK 1.7 or above to execute - it still allows you to build against 1.3 and other JDK versions by Using Toolchains
这是官网原话

qq_23382625
qq_23382625   2015.07.10 16:26

## maven最新版不支持jdk1.6,必须升级jdk,才可以使用

Evankaka
Evankaka   Ds   Rxr 2015.07.11 12:09

JDK1.6要使用maven3.1

sinat_32577235
sinat_32577235   2016.03.20 22:36

你可以下载3.03版本

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Maven3.3.*与JDK版本兼容问题
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor version 51.0     at java.lang.ClassLoader.defineClass1(Native Method)     a
apache-maven-3.3.9,需要jdk7及以上版本
apache-maven-3.3.9,需要jdk7及以上版本 apache-maven-3.3.9,需要jdk7及以上版本
Maven 与支持的JDK版本的关系
Maven Releases History Date format is: YYYY-MM-DD M阿女aven 3 Release Date Version Required Java Version Links 2015-11-14 3.3.9 Java 7 announce, release notes, reference docume
maven创建工程jdk设置为1.6
如果你用eclipse建立maven项目时,新建的项目往往JDK版本很低——1.5!怎么办?修改settings.xml文件,增加profile节点,如下所示:  Java代码            jdk-1.6                      true             1.6                               1.6
maven项目切换jdk1.7-1.6
最近在公司开发一个项目用的jdk1.7,为了于服务器上的其他项目jdk版本一致,准备切换到1.6。 步骤: 1.右键项目“Properties”,在弹出的“Properties”窗口左侧,单击“Project Facets”,打开“Project Facets”页面。在页面中的“Java”下拉列表中,选择1.62.修改pom文件中的编译插件版本,1.7改为1.63.项目右键 - run a
JDK1.6到1.8的注意事项
jdk7都终止更新了,而我们还在用jdk6.。。。 ,安全层面是一个问题,同时有更多的小伙伴早就迫不及待的想使用jdk8才支持的新特性,so,升级计划提上议程,但是升级前的功课还是要做的:   1.sun.* 包缺失问题  如有特殊需求,请下载sun-support-4jkd8.jar ,放到classpath目录  sun.*包 ,已不推荐使用,oracle会逐步进行删除
Maven 版本对应的 JDK 版本
Maven 3 Release Date Version Required Java Version Links 2015-11-14 3.3.9 Java 7 announce, release notes, reference documentation 2015-04-28 3.3.3 announce, release notes,
maven版本对应jdk版本要求
Release Date Version Required Java Version Links 2017-02-28 3.5.0-alpha-1 Java 7 announce , release notes , reference documentation 2015-11-14 3.3.9 announce , 
maven项目显示缺少jdk1.6 tools.jar解决方案
在maven仓库找不到Jar包,在依赖里加入如下内容即可。 <dependency> <groupId>jdk.tools</groupId> <artifactId>jdk.tools</artifactId> <version>1.6</version> <scope>system</scope> <systemP
jdk1.8版本切换至1.6遇到的问题&分析
背景 由于工作原因,我的电脑上目前安装了jdk1.6和jdk1.8 两个版本,并且都是安装版本。 之前因为一些原因(苏宁对接sdk,阿里开发规约)本地默认安装的是jdk.18版本, 但是公司的大部分项目都是用jdk1.6编译,所以后来我本地的默认版本采用了1.6,切换至1.6后,发现阿里Java编码插件无效,经查阅文档得知,阿里Java规划的jdk版本至少是1.8。 参考:http://...