木木的呆呆兽
2015-07-14 05:28
采纳率: 100%
浏览 2.3k

关于JNI,为什么在android 4.4运行正常的程序,在4.0上运行就报错了

事情是这样的:
本身项目是基于android 4.4.2、JDK1.7 编译的,然后公司要求最低版本。
然后我将项目改成了android 2.3.3、JDK1.6编译,修改一些内容后,编译通过,在android 4.4.2的手机上运行正常。
但是现在市场部反应,在低于4.1.X的版本上运行还是有问题,因此我找来一台android 4.0.4内核的手机调试,确实报错了,在JNI模块。
报:UnsatisfiedLinkError,找不到调用的那个Native对应在C中的方法,现在我该怎么办?
android 4.4.x和android4.1.x在JNI上面有什么改变?
既然我程序在4.4.2运行成功,证明代码上没有问题,编译也没有问题,那么问题到底出在哪里??

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

2条回答 默认 最新

相关推荐 更多相似问题