intellij idea 14 控制台下的中文乱码

在java工程中简单的System.out.println("中文")
控制台输出的是??项目的编码改成GBK是??改成UTF-8是乱码.
有没有遇到过这样的问题的,帮下忙谢谢

0

查看全部5条回答

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
idea 14 控制台下的中文乱码
1:打开IntelliJ IDEA 14.0安装路径,小编的安装路径为:D:\Program Files\JetBrains\IntelliJ IDEA 14.0\bin 找到idea.exe.vmoptions 文件,用记事本打开,在最后一行填加: -Dfile.encoding=UTF-8  -Duser.language=en  -Duser.region=US 2:设置ID
IntelliJ idea14输出中文乱码问题
问题描述在win7系统在,IntellJ 的控制台中输出中文时中文会变成问号的形式。解决办法找到安装目标下的idea.exe.vmoptions(我的路径是C:\software\IntelliJ14.1\bin\idea.exe.vmoptions),在后面追加一行–Dfile.encoding=utf8,保存一下,然后重启Intelli就可以了。
IntelliJ IDEA 14控制台中文乱码的解决方法
打开File->Settings->Editer->File Encoding,将IDE Encoding 和 Project Encoding 都改为GBK,同时将IDE右下角的编码也改为GBK即可。 此方法在我的情况下可行,其他情况不保证,但可一试
解决IntelliJ IDEA控制台输出中文乱码问题
一、问题情况: IntelliJ IDEA 控制台输出中文乱码部分如图所示: 二、解决方法: 1.打开tomcat配置页面,Edit Configurations。 2.选择项目部署的tomcat,在配置项VM options文本框中输入-Dfile.encoding=UTF-8,点击Apply或OK即可。 3.尝试重启tomcat,乱码问题解决。 ps:若乱码问题依然...
绝对能解决IntelliJ IDEA 控制台中文乱码问题!!!
如果log4j设置输出编码是utf-8,但是打印到控制台的是中文乱码,可以尝试第一个解决方法。 看了很多网上的,终于解决了。汇总 如图:                              如果其中一种更改不行,可以尝试多种更改。 1:打开intelliidea安装路径,IntelliJIDEA15.0.6\bin找到idea.exe.vmoption文件,打开,在最后一行填加:“...
idea控制台中文乱码解决
1、windows下改intellij安装目录下bin\idea.exe.vmoptions文件 加上 -Dfile.encoding=UTF-8   如下图:   2、设置IDEA server 的编码如下保持一致: tomcat server -- >server->VM options 设置 VM options 为 -Dfile.encoding=UTF-8  如下图:  
解决IntelliJ IDEA 控制台输出乱码问题
1、找到安装Intellij idea目录bin下面的idea.exe.vmoptions和idea64.exe.vmoptions文件,我的安装目录是D:\IntelliJ IDEA\IntelliJ IDEA 15.0.2\bin 2、修改idea.exe.vmoptions和idea64.exe.vmoptions文件,在末尾添加                -Dfile.en
解决IntelliJ Idea中文乱码问题
最近使用IntelliJ Idea时,总出现中文乱码的问题。乱码的根源是字符编码与解码不一致经过一番捣鼓,终于找到解决之道:统一编码本文介绍IntelliJ Idea中如何统一编码打开IntelliJ Idea,点击File菜单-->Settings...在打开的对话框中,选择Editor-->File Encodings更改右侧关于Project的编码,让其保持一致。然后点击OK,a...
IntelliJ IDEA2016 调试窗口、帮助窗口、搜索框中文乱码
编码格式已经设置为UTF-8,但是高度窗口、帮助窗口、搜索框、Setting窗口还是乱码,如下图 发现编码窗口中文是不乱码的,搜索框是乱码的, 原因:字体的原因:我设置的字体是Consolas,此字体是不支持中文的,可以改为其他支持中文的字体,比如说微软雅黑 网上其他文章说需要修改IDE Setting上的相关选项, 文章链接:IntelliJ IDEA 1
解决intellij idea控制台中文乱码(亲测有用)
 解决第一步:修改intellij idea配置文件:找到intellij idea安装目录,bin文件夹下面idea64.exe.vmoptions和idea.exe.vmoptions这两个文件,分别在这两个文件中添加:-Dfile.encoding=UTF-8第二步:找到intellij idea的file---settings---Editor---FileEncodings的Global...
IntelliJ IDEA中文乱码解决
1.  编辑器的乱码,file->settings->appearence里面有个Name设置成支持中文的字 体2.同样还要在settings中的Eidtor->File Encodings里面设置字体编码格式,一般都是UTF-8,GBK。3.找到idea安装目录bin目录下如下图所示两个文件vmoptions后缀,用编辑器打开,在文件末尾添加-Dfile.encoding=UT...
解决intellij idea控制台中文乱码
乱码原因:        1.系统语言:英文             英文系统下遇到乱码问题,分析了程序执行参数如下:             ps -ef | grep java            执行后得到如下的结果,省略了classpath:            /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Cont
IntelliJ IDEA 14.0.2破解注册码文件
Java文件代码: import java.math.BigInteger;import java.util.Date;import java.util.Random;import java.util.Scanner;import java.util.zip.CRC32;public class KeyGen { public static short getCRC(String s, i
Intellij IDEA14.1.2中文菜单包汉化包
Intellij IDEA14.1.2中文菜单包汉化包,下载文件,备份原目录的/lib下的 resources_en.jar 文件然后覆盖文件,即可完成对idea的汉化,支持idea14.1.2
Intellij Idea打包工程时控制台显示乱码
http://ask.csdn.net/questions/376298 这主要是maven编译时编码问题导致的。在Intellij的settings中maven的run配置中设置它的VM Options为-DarchetypeCatalog=internal -Dfile.encoding=GBK,就可以解决maven编译、打包时中文乱码的问题。...
Springboot 之 解决IntelliJ IDEA读取properties配置文件的中文乱码问题
问题描述当在.properties的配置文件中有中文时,读取出来的总是乱码。比如我的application.properties配置文件的内容如下:com.demo.name="Lee" com.demo.want="祝你鸡年大吉"当在程序中读取com.demo.want值时总是会得到乱码,默认是以ISO-8859-1的字符编码读取,尝试在application.properties中添加配置:sp
关于IntelliJ IDEA 控制台中文乱码问题
如果其中一种更改不行,可以尝试多种更改。 1:打开intelliidea安装路径,小编的安装路径为:D:\Program Files (x86)\JetBrains\IntelliJ IDEA 15.0.6\bin找到idea.exe.vmoption文件,用记事本打开,在最后一行填加:“-Dfile.encoding=utf-8”,如图所示,保存。 2:设置idea server编码。在菜单栏
IntelliJ IDEA 控制台中文乱码问题
按以下步骤设置,就可以解决控制台中文乱码显示的问题了。 一、进入设置页。File-->Settings (快捷键:Ctrl+Alt+S) 二、进入IDE Settings 里的 General 项,在File Encoding 中 的 Default encoding 改为 GBK。确定 三、进入IDE Settings 里的 Appearance项,选中Override def
intellij idea控制台输出乱码解决方案
本人下载了一开源工程,该工程采用的是maven进行编译,在导入到itellij idea后,按如下图配置好maven编译环境 但是采用配置好的maven进行编译时,在run的控制台输出窗口中出现乱码,导致无法编译,由于工程是utf-8编码,所以按如下方式配置了工程的编码 网上run控制台输出乱码的解决思路如下: 1)参照上面配置工程编码的方式将Global Encoding/Proj...
IntelliJ IDEA 控制台中文乱码解决
配置Intellij的配置文件 打开Intellij的根目录,找到下图的两个文件(根据你的系统是32位或64位选择其中一个配置文件),在配置文件中添加:-Dfile.encoding=UTF-81配置项目编码及IDE编码进入settings,选择File Encodings,把IDE Encoding和Project Encoding配置为UTF-8,同时将下面的Default encoding ...
IntelliJ IDEA 14 快捷键 非常实用
我认为这样的分类比较符合记忆规律,务必记住这些都是可以IDE自定义的,以下只为默认(我认可了): ==Ctrl== Ctrl + Y 删除行 ctrl + X 剪切行 Ctrl + N 查找类 Ctrl + R 替换 Ctrl + O 选择可覆盖/继承的方法 Ctrl + F 当前代码中查找 Ctrl + J 自动代码提示(提示的是自己定义的代码格式) Ctrl + D 复制
IntelliJ IDEA中文乱码解决办法
IntelliJ IDEA中文乱码解决办法 1. 预热 刚刚接触IntelliJ IDEA几天,在易用性方面的确比Eclipse好很多,比较智能,各种插件、工具都已经集成,和Mac OS X类似——开箱即用,并且在试用了之后在开源中国三折(后悔2折的时候没有下手)购买了授权。 但是还是老大难问题——中文乱码,让我不得不花费了一些时间去折腾它,这一点就不如Eclipse了,没有遇到
intellij idea 控制台输出中文乱码问题解决办法
初次使用intellij idea 15的时候遇到了在项目中控制台输出的中文会变成乱码,下面给出解决办法1.在File -Setting中设置如下图所示 把IDE 和项目都设置成为UTF-82.打开 intellij idea15的安装目录 的bin 文件夹下的idea.exe.vmoptions ,用记事本打开,在文件末尾处添加 -Dfile.encoding=UTF-8 如下图3.设置tomc...
IDEA14.0.2安装教程
IDEA14.0.2安装教程 如有不妥之处,请多多指教 1.下载IDEA的安装包,点击ideaIU-14.0.2.exe文件,打开如下界面,然后点击Next继续下一步。 2.点击同意,继续下一步。 3.自定义安装路径,这里我安在F:\IDEA\IntelliJ IDEA 14.0.2,点击Next继续。 4.这一步是配置你自己的IntelliJ IDEA 安装选项:勾选创建快捷方法,勾选.Java
终极解决解决IntelliJ IDEA中文乱码问题
1.首先是编辑器的乱码,这个很好解决,file->settings->appearence里面有个Name设置成支持中文的字 体(这个很重要) 同样还要再settings中的Eidtor->File Encodings里面设置字体编码格式,一般都是UTF-8,GBK什么的也行。 2.找到idea安装目录bin目录下如下图所示两个文件,用编辑器打开,在文件末尾添加 -D...
linux 下面intelliJ idea中文乱码解决
linux 下面intelliJ idea中文乱码解决办法1、下载simsun.zip 下载地址: http://dl.pconline.com.cn/download/367689-1.html2、将simsun.ttf 拷贝到linux系统中的 /usr/share/fonts/truetype目录3、建立字体索引信息,更新字体缓存:    # cd /usr/share/fonts/true...
IntelliJ IDEA 在 mac 上的乱码问题
IntelliJ IDEA 2016.3 版本在mac 上,不同字体显示出现了乱码: 使用Source Code Pro字体时出现乱码,将字体替换为Courier New 显示正常。配置方法:IntelliJ IDEA -> Preferences -> Appearence & Behavior -> Appearence, 如下图所示:
IntelliJ IDEA14安装、配置教程
IDEA安装、配置记录@(IEDA和maven构建项目)[IntelliJ IDEA|Maven|安装配置教程]IDEA安装配置记录 一安装 二配置 三新建项目 四参考资料 五后记一、安装 注册,随便搜个注册码 自定义默认插件,进去看看觉得需要保留,后期可以修改。 现选截图(后期可以对照图片查看哪些插件需要安装却没有安装)下: 特色插件基本不需要安装 二、配置 开始配置 主要是对字体、
两分钟解决IntelliJ IDEA中文乱码问题
1.首先是编辑器的乱码,这个很好解决,file->settings->appearence里面有个Name设置成支持中文的字 体(这个很重要)同样还要再settings中的Eidtor->File Encodings里面设置字体编码格式,一般都是UTF-8,GBK什么的也行。2.找到idea安装目录bin目录下如下图所示两个文件,用编辑器打开,在文件末尾添加 -Dfile.encoding=UTF-
IntelliJ IDEA 控制台输出中文乱码问题的解决方法
首先,找到 IntelliJ IDEA 的安装目录,进入“bin”目录下,定位到“ idea.vmoptions ”文件,如下图所示:双击打开“ idea.vmoptions ”文件,如下图所示:然后,在其中追加“ -Dfile.encoding=UTF-8 ”代码,如下图所示:最后,在 IntelliJ IDEA 中的“Run/Debug Configurations”中,修改虚拟机参数“ VM
Intellij IDEA 14.1.4安装详细图解与注册方法
1. 先下载Intellij IDEA 14.1.4安装文件,推荐下载旗舰版 ①官网下载地址:https://www.jetbrains.com/idea/#chooseYourEdition 尽管可以破解,但是还是希望大家多多支持正版!或者使用社区版,社区版不用破解。 若资金允许,请点击https://www.jetbrains.com/idea/buy/购买正版,谢谢合作 。 学生凭学生证可免费申请正版授权 | 创业公司可5折购买正版授权。 ② 360云盘下载:https://yunpan.cn/
IDEA--解决IntelliJ IDEA中文乱码问题
1.首先是编辑器的乱码,这个很好解决,file->settings->appearence里面有个Name设置成支持中文的字 体(这个很重要) 同样还要再settings中的Eidtor->File Encodings里面设置字体编码格式,一般都是UTF-8,GBK什么的也行。 2.找到idea安装目录bin目录下如下图所示两个文件,用编辑器打开,在文件末尾添加 -D...
intellij IDEA使用教程
intellij IDEA使用教程,intellij IDEA使用教程intellij IDEA使用教程intellij IDEA使用教程intellij IDEA使用教程intellij IDEA使用教程
解决IntelliJ IDEA控制台中文乱码问题
1、Setting–>Editor–>File Encodings2、Tomcat VM Options设置:-Dfile.encoding=UTF-83、idea vmOptions设置:-Dfile.encoding=UTF-8
(一)Intellij output 中文乱码
使用intellij有一段时间了,intellij output中文乱码,每次使用这两点解决,就可以解决乱码问题。 1、修改启动参数 修改安装Intellij目录下的C:\Program Files (x86)\JetBrains\IntelliJ IDEA 14.0.2\bin\idea.exe.vmoptions(自己的安装目录),在末尾加上启动Intellij的参数,如下。 -serv
idea中的中文注释出现乱码的解决方案
环境:win10,idea13.1.1   我是个idea的忠实用户,新公司的项目都是用eclipse做的,通过svn拉下代码后发现,注释的内容里,中文内容都是乱码。问过项目负责人,说可能是GBK编码。 但是,我通过idea的setting设置了编码,试了5种编码都没用,中文内容还是乱码。最后还是自己试出来解决方案。 详细的原因请参考最后的讲解。   乱码示例图
IntelliJ IDEA 乱码解决方案 (项目代码、控制台等)
IntelliJ IDEA 乱码解决方案 (项目代码、控制台等)
解决IntelliJ Idea中文乱码问题、修改IDEA编码
见:http://blog.csdn.net/shfqbluestone/article/details/50245547 有两种办法可以修改 IntelliJ IDEA 的文件编码(IDE 版本为 14.1.4) File->Settings->Editor->File Encodings 这种方式修改的文件编码方式只对当前 project 起作用,每次新建了一个
IntelliJ IDEA 控制台中文乱码
1. 预热 刚刚接触IntelliJ IDEA几天,在易用性方面的确比Eclipse好很多,比较智能,各种插件、工具都已经集成,和Mac OS X类似——开箱即用,并且在试用了之后在开源中国三折(后悔2折的时候没有下手)购买了授权。 但是还是老大难问题——中文乱码,让我不得不花费了一些时间去折腾它,这一点就不如Eclipse了,没有遇到过乱码问题。 乱码问题表现在使用Web Se
Intellij idea 控制台及RestClient中文乱码解决办法
修改启动配置文件打开IntelliJ IDEA 安装路径,小编的安装路径为:D:\ProgramFiles\JetBrains\IntelliJ IDEA 2017.1\bin 找到idea64.exe.vmoptions 文件,用记事本打开,在最后一行填加:“-Dfile.encoding=UTF-8”。如果是x86机器请修改idea.exe.vmoptions。-Xms128m -Xmx750m
文章热词 设计制作学习 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型
相关热词 server的安全控制模型是什么 sql ios获取idfa android title搜索 java控制台五子棋学习 idea网页制作视频教程