桐桐-Dragon
2015-07-25 03:04
采纳率: 0%
浏览 2.5k

eclipse中指定父pom的compile插件版本后子工程报错

开发环境:eclipse mars,m2eclipse,maven3.3(external)
parent pom中,Management配置compile插件,但是不指定版本,
son pom中不配置compile-Plugin,
此时执行编译:发现使用的是compile plugin version = 3.1
问题开始:
此时修改 Management配置compile插件version= other,比如3.3
此时项目仍然可以正常编译,发现使用的compile Plugin version= 3.3
但是此时:在IDE中查看发现,子工程名称前,报红叉,但是没有错误提示
求指点报错原因。

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • Evankaka 2015-07-25 04:00

    那应该就是JDK版本的问题了,更改下编译使用的JDK版本

    评论
    解决 无用
    打赏 举报
  • Mr-稻帅 2015-07-25 05:02

    子项目 update maven project试试

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题