RuoYeKnight
Knimet
采纳率63.3%
2015-08-05 10:03 阅读 1.8k
已采纳

hibernatetemplate不能用了吗??

刚才项目run on server报错,百度了一下解决方案说Spring3.1取消了HibernateTemplate,因为Hibernate4的事务管理已经很好了,不用Spring再扩展了。所以以前的Dao需要改写,直接调用Hibernate 的Session进行持久化。
这个意思是hibernatetemplate不能用了吗。。。。
那替代品可以用myeclipse生成的那个hibernatesessionfactory吗?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • 已采纳
    bulusli3 lhl_lqc 2015-08-05 10:19

    如果想用hibernatetemplate的话,可以用spring3.0的包。如果要用spring3.1以上的包,那就自己通过sessionFactory实现吧。

    点赞 评论 复制链接分享

相关推荐