liuerchaohappy
liuerchaohappy
2015-08-15 05:58
采纳率: 28.6%
浏览 1.8k

Linux利用yum安装软件问题

电脑之前利用源码升级GCC到4.9.1,后来又利用yum方式升级subversion,装好subversion之后,GCC又变回到4.4.7版本,请问是怎么回事?subversion依赖gcc,利用yum安装,会重新安装gcc吗?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • oyljerry
    oyljerry 2015-08-15 08:14
    已采纳

    你可以用yum方式安装系统的gcc版本。而gcc4.9用源码编译,安装到usr local目录。然后把路径添加到系统目录。这样你可以用到新版本gcx。如果想区分。可以命名为gcc4.9等。这样gcc还是系统的。你用gcc4.9来用新版本

    点赞 评论
  • caozhy

    yum上的版本不一定是最新的。RH系又比较保守
    你再运行下 yum -y install gcc-c++ 看看呢。
    也可以多版本共存。

    点赞 评论

相关推荐