deyuzhi
is_thinking
2015-08-23 13:44
采纳率: 86%
浏览 5.2k

安装npm install时出现错误

我是在win8上面操作,需要在github上面克隆一个项目在本地编辑

在nodejs官网上面下载了一个安装包,安装后进行了如下操作

1:新建了一个文件夹,用virtualenv做成虚拟环境

2:将github上面的项目clone到该文件夹

3:将该文件夹进入venv虚拟环境

4:安装Python的依赖包flask之类的

5:进入项目的static文件夹,(这里面有package.json文件,dependencies里有一项是"sass-loader": "^2.0.0",)

输入了如下命令:npm install

错误如下:

 Building: C:\Program Files\nodejs\node.exe node_modules\pangyp\bin\node-gyp rebuild --libsass_ext= --libsass_cflags= --libsa
ss_ldflags= --libsass_library=
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: node-v0.12.7.tar.gz local checksum 88bc1dbe3f1da75a4b5eabea55ab1f40a99373b8ae7356d2374e8053ced04ec0 no
42e53067127a5061415be7e12f39d
gyp ERR! stack     at deref (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\lib\install.js:304:20)
gyp ERR! stack     at Request.<anonymous> (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\lib\install.js:3
gyp ERR! stack     at Request.emit (events.js:129:20)
gyp ERR! stack     at IncomingMessage.<anonymous> (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\node_mod
gyp ERR! stack     at IncomingMessage.emit (events.js:129:20)
gyp ERR! stack     at _stream_readable.js:908:16
gyp ERR! stack     at process._tickCallback (node.js:355:11)
gyp ERR! System Windows_NT 6.3.9600
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "E:\\project1_2\\shijuan\\node_modules\\node-sass\\node_modules\\pang
ibsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd E:\project1_2\shijuan\node_modules\node-sass
gyp ERR! node -v v0.12.7
gyp ERR! pangyp -v v2.3.0
gyp ERR! not ok
Build failed

不知道是哪个地方的原因,希望各位老师不吝赐教,谢谢

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • oyljerry
    oyljerry 2015-08-24 15:29
    已采纳

    安装的包对编译器vs有依赖,装了vs2012,解决了依赖问题。

    点赞 评论
  • devmiao
    devmiao 2015-08-23 14:24

    node-v0.12.7.tar.gz复制或者下载错误,验证不通过,重新下载

    点赞 评论
  • deyuzhi
    is_thinking 2015-08-24 15:18

    这个问题是在安装了vs2012后自动消失的,不知道具体为什么

    点赞 评论
  • oyljerry
    oyljerry 2015-08-24 15:31

    安装的包对编译器vs有依赖,装了vs2012,解决了依赖问题。

    点赞 评论

相关推荐