foxli12345
foxli12345
采纳率66.7%
2015-08-24 13:22 阅读 5.1k
已采纳

为什么新建web项目没有 java EE 7.0 可以选择

我最近在做websocket 相关,上网查了一下必须 至少要 java EE 7.0 以上才支持,所以我以前用的是 jdk1.6.0_45 和tomcat 7, 新建web项目的时候只有 java EE 6.0 和 5.0可选,所以我就使用了jdk1.7.0_79 ,但是新建web project的时候,J2EE Specification Level 中还是没有 Java EE 7.0可选,请问是什么原因呢?最后添加的Liabrary中也没有Java EE 7 Library ,求指点。图片说明
图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

5条回答 默认 最新

  • 已采纳
    strutce 丵鹰 2015-08-24 16:31

    myeclipse版本旧了

    点赞 1 评论 复制链接分享
  • caozhy 从今以后生命中的每一秒都属于我爱的人 2015-08-24 14:39

    你的版本太旧了吧。Java EE 7是2013年底发布的。你的myeclipse是什么版本的

    点赞 1 评论 复制链接分享
  • cuiwei1026522829 另一花生 2015-08-24 16:09

    一般来说,myeclipse版本最新的,会配置J2EE7.0

    点赞 1 评论 复制链接分享
  • Evankaka Evankaka 2015-08-24 15:49

    Myeclips中添加JDK,把1,7和1.8的都加上!

    点赞 评论 复制链接分享
  • yuke198907 yuke198907 2015-08-26 05:46

    版本低了,手动给加上吧

    点赞 评论 复制链接分享

相关推荐