weixin_39914975
weixin_39914975
2020-11-29 20:01

trinity

I try to install trinity by spack but face the error



$ spack install trinity %gcc.4.0
==> Error: An unsatisfiable version constraint has been detected for spec:

    r.6.0%gcc.4.0~X~external-lapack~memory_profiling~rmath arch=linux-centos7-x86_64
        ^bzip2.0.8%gcc.4.0+shared arch=linux-centos7-x86_64
            ^diffutils.7%gcc.4.0 arch=linux-centos7-x86_64
        ^cairo.16.0%gcc.4.0~X+pdf arch=linux-centos7-x86_64
            ^fontconfig.12.3%gcc.4.0 arch=linux-centos7-x86_64
                ^font-util.3.1%gcc.4.0 fonts=encodings,font-adobe-100dpi,font-adobe-75dpi,font-adobe-utopia-100dpi,font-adobe-utopia-75dpi,font-adobe-utopia-type1,font-alias,font-arabic-misc,font-bh-100dpi,font-bh-75dpi,font-bh-lucidatypewriter-100dpi,font-bh-lucidatypewriter-75dpi,font-bh-ttf,font-bh-type1,font-bitstream-100dpi,font-bitstream-75dpi,font-bitstream-speedo,font-bitstream-type1,font-cronyx-cyrillic,font-cursor-misc,font-daewoo-misc,font-dec-misc,font-ibm-type1,font-isas-misc,font-jis-misc,font-micro-misc,font-misc-cyrillic,font-misc-ethiopic,font-misc-meltho,font-misc-misc,font-mutt-misc,font-schumacher-misc,font-screen-cyrillic,font-sun-misc,font-winitzki-cyrillic,font-xfree86-type1 arch=linux-centos7-x86_64
                    ^autoconf.69%gcc.4.0 arch=linux-centos7-x86_64
                        ^m4.4.18%gcc.4.0+sigsegv arch=linux-centos7-x86_64
                            ^libsigsegv
                        ^perl.26.2%gcc.4.0+cpanm+shared+threads arch=linux-centos7-x86_64
                            ^gdbm.18.1%gcc.4.0 arch=linux-centos7-x86_64
                                ^readline.0%gcc.4.0 arch=linux-centos7-x86_64
                                    ^ncurses.1%gcc.4.0~symlinks~termlib arch=linux-centos7-x86_64
                                        ^pkgconf.6.1%gcc.4.0 arch=linux-centos7-x86_64
                    ^automake.16.1%gcc.4.0 arch=linux-centos7-x86_64
                    ^bdftopcf.0.5%gcc.4.0 arch=linux-centos7-x86_64
                        ^fontsproto.1.3%gcc.4.0 arch=linux-centos7-x86_64
                            ^util-macros.19.1%gcc.4.0 arch=linux-centos7-x86_64
                        ^libxfont.5.2%gcc.4.0 arch=linux-centos7-x86_64
                            ^freetype.9.1%gcc.4.0 arch=linux-centos7-x86_64
                                ^libpng.6.34%gcc.4.0 arch=linux-centos7-x86_64
                                    ^zlib.2.11%gcc.4.0+optimize+pic+shared arch=linux-centos7-x86_64
                            ^libfontenc.1.3%gcc.4.0 arch=linux-centos7-x86_64
                                ^xproto.0.31%gcc.4.0 arch=linux-centos7-x86_64
                            ^xtrans.3.5%gcc.4.0 arch=linux-centos7-x86_64
                    ^mkfontdir.0.7%gcc.4.0 arch=linux-centos7-x86_64
                        ^mkfontscale.1.2%gcc.4.0 arch=linux-centos7-x86_64
                ^gperf
                ^libxml2.9.9%gcc.4.0~python arch=linux-centos7-x86_64
                    ^libiconv.15%gcc.4.0 arch=linux-centos7-x86_64
                    ^xz.2.4%gcc.4.0 arch=linux-centos7-x86_64
            ^glib.56.3%gcc.4.0~libmount tracing=none arch=linux-centos7-x86_64
                ^gettext.19.8.1%gcc.4.0+bzip2+curses+git~libunistring+libxml2+tar+xz arch=linux-centos7-x86_64
                    ^tar
                ^libffi.2.1%gcc.4.0 arch=linux-centos7-x86_64
                ^pcre.42%gcc.4.0~jit+multibyte+utf arch=linux-centos7-x86_64
                ^python.7.16%gcc.4.0+bz2+ctypes+dbm+lzma~nis~optimizations+pic+pyexpat+pythoncmd+readline+shared+sqlite3+ssl~tix~tkinter+ucs4~uuid+zlib arch=linux-centos7-x86_64
                    ^expat
                    ^openssl.1.1b%gcc.4.0+systemcerts arch=linux-centos7-x86_64
                    ^sqlite.0.8:
            ^pixman.38.0%gcc.4.0 arch=linux-centos7-x86_64
        ^curl.63.0%gcc.4.0~darwinssl~gssapi~libssh~libssh2~nghttp2 arch=linux-centos7-x86_64
        ^icu4c.1%gcc.4.0 cxxstd=11 arch=linux-centos7-x86_64
        ^libjpeg-turbo.0.2%gcc.4.0 arch=linux-centos7-x86_64
            ^cmake.15.1%gcc.4.0~doc+ncurses+openssl+ownlibs~qt arch=linux-centos7-x86_64
            ^nasm
        ^libtiff.0.10%gcc.4.0 arch=linux-centos7-x86_64
        ^openjdk.0.2%gcc.4.0 arch=linux-centos7-x86_64
        ^pango.41.0%gcc.4.0~X arch=linux-centos7-x86_64
            ^gobject-introspection.56.1%gcc.4.0 arch=linux-centos7-x86_64
                ^bison.0.5%gcc.4.0 arch=linux-centos7-x86_64
                    ^help2man.47.8%gcc.4.0 arch=linux-centos7-x86_64
                ^flex.6.4%gcc.4.0+lex arch=linux-centos7-x86_64
                    ^libtool.4.6%gcc.4.0 arch=linux-centos7-x86_64
            ^harfbuzz.3.1%gcc.4.0 arch=linux-centos7-x86_64
        ^tcl.6.8%gcc.4.0 arch=linux-centos7-x86_64


while trying to concretize the partial spec:

    r-edger.22.3%gcc.4.0 arch=linux-centos7-x86_64
        ^r-locfit.5-9.1%gcc.4.0 arch=linux-centos7-x86_64
            ^r.6.0%gcc.4.0~X~external-lapack~memory_profiling~rmath arch=linux-centos7-x86_64
                ^bzip2.0.8%gcc.4.0+shared arch=linux-centos7-x86_64
                    ^diffutils.7%gcc.4.0 arch=linux-centos7-x86_64
                ^cairo.16.0%gcc.4.0~X+pdf arch=linux-centos7-x86_64
                    ^fontconfig.12.3%gcc.4.0 arch=linux-centos7-x86_64
                        ^font-util.3.1%gcc.4.0 fonts=encodings,font-adobe-100dpi,font-adobe-75dpi,font-adobe-utopia-100dpi,font-adobe-utopia-75dpi,font-adobe-utopia-type1,font-alias,font-arabic-misc,font-bh-100dpi,font-bh-75dpi,font-bh-lucidatypewriter-100dpi,font-bh-lucidatypewriter-75dpi,font-bh-ttf,font-bh-type1,font-bitstream-100dpi,font-bitstream-75dpi,font-bitstream-speedo,font-bitstream-type1,font-cronyx-cyrillic,font-cursor-misc,font-daewoo-misc,font-dec-misc,font-ibm-type1,font-isas-misc,font-jis-misc,font-micro-misc,font-misc-cyrillic,font-misc-ethiopic,font-misc-meltho,font-misc-misc,font-mutt-misc,font-schumacher-misc,font-screen-cyrillic,font-sun-misc,font-winitzki-cyrillic,font-xfree86-type1 arch=linux-centos7-x86_64
                            ^autoconf.69%gcc.4.0 arch=linux-centos7-x86_64
                                ^m4.4.18%gcc.4.0+sigsegv arch=linux-centos7-x86_64
                                    ^libsigsegv
                                ^perl.26.2%gcc.4.0+cpanm+shared+threads arch=linux-centos7-x86_64
                                    ^gdbm.18.1%gcc.4.0 arch=linux-centos7-x86_64
                                        ^readline.0%gcc.4.0 arch=linux-centos7-x86_64
                                            ^ncurses.1%gcc.4.0~symlinks~termlib arch=linux-centos7-x86_64
                                                ^pkgconf.6.1%gcc.4.0 arch=linux-centos7-x86_64
                            ^automake.16.1%gcc.4.0 arch=linux-centos7-x86_64
                            ^bdftopcf.0.5%gcc.4.0 arch=linux-centos7-x86_64
                                ^fontsproto.1.3%gcc.4.0 arch=linux-centos7-x86_64
                                    ^util-macros.19.1%gcc.4.0 arch=linux-centos7-x86_64
                                ^libxfont.5.2%gcc.4.0 arch=linux-centos7-x86_64
                                    ^freetype.9.1%gcc.4.0 arch=linux-centos7-x86_64
                                        ^libpng.6.34%gcc.4.0 arch=linux-centos7-x86_64
                                            ^zlib.2.11%gcc.4.0+optimize+pic+shared arch=linux-centos7-x86_64
                                    ^libfontenc.1.3%gcc.4.0 arch=linux-centos7-x86_64
                                        ^xproto.0.31%gcc.4.0 arch=linux-centos7-x86_64
                                    ^xtrans.3.5%gcc.4.0 arch=linux-centos7-x86_64
                            ^mkfontdir.0.7%gcc.4.0 arch=linux-centos7-x86_64
                                ^mkfontscale.1.2%gcc.4.0 arch=linux-centos7-x86_64
                        ^gperf
                        ^libxml2.9.9%gcc.4.0~python arch=linux-centos7-x86_64
                            ^libiconv.15%gcc.4.0 arch=linux-centos7-x86_64
                            ^xz.2.4%gcc.4.0 arch=linux-centos7-x86_64
                    ^glib.56.3%gcc.4.0~libmount tracing=none arch=linux-centos7-x86_64
                        ^gettext.19.8.1%gcc.4.0+bzip2+curses+git~libunistring+libxml2+tar+xz arch=linux-centos7-x86_64
                            ^tar
                        ^libffi.2.1%gcc.4.0 arch=linux-centos7-x86_64
                        ^pcre.42%gcc.4.0~jit+multibyte+utf arch=linux-centos7-x86_64
                        ^python.7.16%gcc.4.0+bz2+ctypes+dbm+lzma~nis~optimizations+pic+pyexpat+pythoncmd+readline+shared+sqlite3+ssl~tix~tkinter+ucs4~uuid+zlib arch=linux-centos7-x86_64
                            ^expat
                            ^openssl.1.1b%gcc.4.0+systemcerts arch=linux-centos7-x86_64
                            ^sqlite.0.8:
                    ^pixman.38.0%gcc.4.0 arch=linux-centos7-x86_64
                ^curl.63.0%gcc.4.0~darwinssl~gssapi~libssh~libssh2~nghttp2 arch=linux-centos7-x86_64
                ^icu4c.1%gcc.4.0 cxxstd=11 arch=linux-centos7-x86_64
                ^libjpeg-turbo.0.2%gcc.4.0 arch=linux-centos7-x86_64
                    ^cmake.15.1%gcc.4.0~doc+ncurses+openssl+ownlibs~qt arch=linux-centos7-x86_64
                    ^nasm
                ^libtiff.0.10%gcc.4.0 arch=linux-centos7-x86_64
                ^openjdk.0.2%gcc.4.0 arch=linux-centos7-x86_64
                ^pango.41.0%gcc.4.0~X arch=linux-centos7-x86_64
                    ^gobject-introspection.56.1%gcc.4.0 arch=linux-centos7-x86_64
                        ^bison.0.5%gcc.4.0 arch=linux-centos7-x86_64
                            ^help2man.47.8%gcc.4.0 arch=linux-centos7-x86_64
                        ^flex.6.4%gcc.4.0+lex arch=linux-centos7-x86_64
                            ^libtool.4.6%gcc.4.0 arch=linux-centos7-x86_64
                    ^harfbuzz.3.1%gcc.4.0 arch=linux-centos7-x86_64
                ^tcl.6.8%gcc.4.0 arch=linux-centos7-x86_64
            ^r-lattice.20-35%gcc.4.0 arch=linux-centos7-x86_64

r-edger requires r version 3.5.0:3.5.9, but spec asked for 3.6.0

According to the error message, I also loaded R3.6.0,command is as follows but the error content is the same.What else I can do to solve this problem?



$ spack install r %gcc.4.0
$ spack install trinity %gcc.4.0 ^r.6.0

该提问来源于开源项目:spack/spack

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39531604 wdk199512 5月前

    Similar problem here to install trinity. I found a not-too-elegant workaround:

    spack spec trinity.6.6 %gcc.4.0 ^r@:3.5.3+X ^r-edger.22.3 ^r-biocgenerics.26.0 ^py-numpy.16.4 ^perl.28.0 ^r-amap.8-16

    This works well for me, currently. You may have to resolve the issue of perl-dbfile prior to the installation of trinity. Please refer to this pull request.

    点赞 评论 复制链接分享
  • weixin_39949894 weixin_39949894 5月前

    If think there's a misunderstanding with the message. What is saying is that: 1. You asked for r.6.0 (or you left it blank and that was the default) 2. r-edger can build only with r version from 3.5.0 to 3.5.9

    点赞 评论 复制链接分享
  • weixin_39718521 weixin_39718521 5月前

    Does spack spec r-edger ^r@:3.5.9 work?

    点赞 评论 复制链接分享
  • weixin_39914975 weixin_39914975 5月前

    I add information using r3.5.0 when install trinity

    $ spack install trinity %gcc.3.0 ^r.5.0 ==> Error: An unsatisfiable version constraint has been detected for spec:

    r.5.0%gcc.3.0~X~external-lapack~memory_profiling~rmath arch=linux-centos7-x86_64
        ^bzip2.0.8%gcc.3.0+shared arch=linux-centos7-x86_64
            ^diffutils.7%gcc.3.0 arch=linux-centos7-x86_64
        ^cairo.16.0%gcc.3.0~X+pdf arch=linux-centos7-x86_64
            ^fontconfig.12.3%gcc.3.0 arch=linux-centos7-x86_64
                ^font-util.3.1%gcc.3.0 fonts=encodings,font-adobe-100dpi,font-adobe-75dpi,font-adobe-utopia-100dpi,font-adobe-utopia-75dpi,font-adobe-utopia-type1,font-alias,font-arabic-misc,font-bh-100dpi,font-bh-75dpi,font-bh-lucidatypewriter-100dpi,font-bh-lucidatypewriter-75dpi,font-bh-ttf,font-bh-type1,font-bitstream-100dpi,font-bitstream-75dpi,font-bitstream-speedo,font-bitstream-type1,font-cronyx-cyrillic,font-cursor-misc,font-daewoo-misc,font-dec-misc,font-ibm-type1,font-isas-misc,font-jis-misc,font-micro-misc,font-misc-cyrillic,font-misc-ethiopic,font-misc-meltho,font-misc-misc,font-mutt-misc,font-schumacher-misc,font-screen-cyrillic,font-sun-misc,font-winitzki-cyrillic,font-xfree86-type1 arch=linux-centos7-x86_64
                    ^autoconf.69%gcc.3.0 arch=linux-centos7-x86_64
                        ^m4.4.18%gcc.3.0+sigsegv arch=linux-centos7-x86_64
                            ^libsigsegv
                        ^perl.26.2%gcc.3.0+cpanm+shared+threads arch=linux-centos7-x86_64
                            ^gdbm.18.1%gcc.3.0 arch=linux-centos7-x86_64
                                ^readline.0%gcc.3.0 arch=linux-centos7-x86_64
                                    ^ncurses.1%gcc.3.0~symlinks~termlib arch=linux-centos7-x86_64
                                        ^pkgconf.6.1%gcc.3.0 arch=linux-centos7-x86_64
                    ^automake.16.1%gcc.3.0 arch=linux-centos7-x86_64
                    ^bdftopcf.0.5%gcc.3.0 arch=linux-centos7-x86_64
                        ^fontsproto.1.3%gcc.3.0 arch=linux-centos7-x86_64
                            ^util-macros.19.1%gcc.3.0 arch=linux-centos7-x86_64
                        ^libxfont.5.2%gcc.3.0 arch=linux-centos7-x86_64
                            ^freetype.9.1%gcc.3.0 arch=linux-centos7-x86_64
                                ^libpng.6.34%gcc.3.0 arch=linux-centos7-x86_64
                                    ^zlib.2.11%gcc.3.0+optimize+pic+shared arch=linux-centos7-x86_64
                            ^libfontenc.1.3%gcc.3.0 arch=linux-centos7-x86_64
                                ^xproto.0.31%gcc.3.0 arch=linux-centos7-x86_64
                            ^xtrans.3.5%gcc.3.0 arch=linux-centos7-x86_64
                    ^mkfontdir.0.7%gcc.3.0 arch=linux-centos7-x86_64
                        ^mkfontscale.1.2%gcc.3.0 arch=linux-centos7-x86_64
                ^gperf
                ^libxml2.9.9%gcc.3.0~python arch=linux-centos7-x86_64
                    ^libiconv.15%gcc.3.0 arch=linux-centos7-x86_64
                    ^xz.2.4%gcc.3.0 arch=linux-centos7-x86_64
            ^glib.56.3%gcc.3.0~libmount tracing=none arch=linux-centos7-x86_64
                ^gettext.19.8.1%gcc.3.0+bzip2+curses+git~libunistring+libxml2+tar+xz arch=linux-centos7-x86_64
                    ^tar
                ^libffi.2.1%gcc.3.0 arch=linux-centos7-x86_64
                ^pcre.42%gcc.3.0~jit+multibyte+utf arch=linux-centos7-x86_64
                ^python.7.16%gcc.3.0+bz2+ctypes+dbm+lzma~nis~optimizations+pic+pyexpat+pythoncmd+readline+shared+sqlite3+ssl~tix~tkinter+ucs4~uuid+zlib arch=linux-centos7-x86_64
                    ^expat
                    ^openssl.1.1c%gcc.3.0+systemcerts arch=linux-centos7-x86_64
                    ^sqlite.0.8:
            ^pixman.38.0%gcc.3.0 arch=linux-centos7-x86_64
        ^curl.63.0%gcc.3.0~darwinssl~gssapi~libssh~libssh2~nghttp2 arch=linux-centos7-x86_64
        ^icu4c.1%gcc.3.0 cxxstd=11 arch=linux-centos7-x86_64
        ^libjpeg-turbo.0.2%gcc.3.0 arch=linux-centos7-x86_64
            ^cmake.15.1%gcc.3.0~doc+ncurses+openssl+ownlibs~qt arch=linux-centos7-x86_64
            ^nasm
        ^libtiff.0.10%gcc.3.0 arch=linux-centos7-x86_64
        ^openjdk.0.2%gcc.3.0 arch=linux-centos7-x86_64
        ^pango.41.0%gcc.3.0~X arch=linux-centos7-x86_64
            ^gobject-introspection.56.1%gcc.3.0 arch=linux-centos7-x86_64
                ^bison.0.5%gcc.3.0 arch=linux-centos7-x86_64
                    ^help2man.47.8%gcc.3.0 arch=linux-centos7-x86_64
                ^flex.6.4%gcc.3.0+lex arch=linux-centos7-x86_64
                    ^libtool.4.6%gcc.3.0 arch=linux-centos7-x86_64
            ^harfbuzz.3.1%gcc.3.0 arch=linux-centos7-x86_64
        ^tcl.6.8%gcc.3.0 arch=linux-centos7-x86_64
    
     while trying to concretize the partial spec:
    
       r-biocgenerics.30.0%gcc.3.0 arch=linux-centos7-x86_64
    
    r-biocgenerics requires r version 3.6.0:, but spec asked for 3.5.0
    
    点赞 评论 复制链接分享
  • weixin_39914975 weixin_39914975 5月前

    In addition that spack spec r-edger ^r@:3.5.0 and spack spec r-biocgenerics ^r.6.0 work as follow

     $spack spec r-biocgenerics ^r.6.0
     Input spec
     --------------------------------
     r-biocgenerics
         ^r.6.0
    
     Concretized
     --------------------------------
     r-biocgenerics.30.0%gcc.3.0 arch=linux-centos7-x86_64
         ^r.6.0%gcc.3.0~X~external-lapack~memory_profiling~rmath arch=linux-centos7-x86_64
             ^bzip2.0.8%gcc.3.0+shared arch=linux-centos7-x86_64
                 ^diffutils.7%gcc.3.0 arch=linux-centos7-x86_64
             ^cairo.16.0%gcc.3.0~X+pdf arch=linux-centos7-x86_64
                 ^fontconfig.12.3%gcc.3.0 arch=linux-centos7-x86_64
                     ^font-util.3.1%gcc.3.0 fonts=encodings,font-adobe-100dpi,font-adobe-75dpi,font-adobe-utopia-100dpi,font-adobe-utopia-75dpi,font-adobe-utopia-type1,font-alias,font-arabic-misc,font-bh-100dpi,font-bh-75dpi,font-bh-lucidatypewriter-100dpi,font-bh-lucidatypewriter-75dpi,font-bh-ttf,font-bh-type1,font-bitstream-100dpi,font-bitstream-75dpi,font-bitstream-speedo,font-bitstream-type1,font-cronyx-cyrillic,font-cursor-misc,font-daewoo-misc,font-dec-misc,font-ibm-type1,font-isas-misc,font-jis-misc,font-micro-misc,font-misc-cyrillic,font-misc-ethiopic,font-misc-meltho,font-misc-misc,font-mutt-misc,font-schumacher-misc,font-screen-cyrillic,font-sun-misc,font-winitzki-cyrillic,font-xfree86-type1 arch=linux-centos7-x86_64
                         ^autoconf.69%gcc.3.0 arch=linux-centos7-x86_64
                             ^m4.4.18%gcc.3.0 patches=3877ab548f88597ab2327a2230ee048d2d07ace1062efe81fc92e91b7f39cd00,fc9b61654a3ba1a8d6cd78ce087e7c96366c290bc8d2c299f09828d793b853c8 +sigsegv arch=linux-centos7-x86_64
                                 ^libsigsegv.11%gcc.3.0 arch=linux-centos7-x86_64
                             ^perl.26.2%gcc.3.0+cpanm patches=0eac10ed90aeb0459ad8851f88081d439a4e41978e586ec743069e8b059370ac +shared+threads arch=linux-centos7-x86_64
                                 ^gdbm.18.1%gcc.3.0 arch=linux-centos7-x86_64
                                     ^readline.0%gcc.3.0 arch=linux-centos7-x86_64
                                         ^ncurses.1%gcc.3.0~symlinks~termlib arch=linux-centos7-x86_64
                                             ^pkgconf.6.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^automake.16.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^bdftopcf.0.5%gcc.3.0 arch=linux-centos7-x86_64
                             ^fontsproto.1.3%gcc.3.0 arch=linux-centos7-x86_64
                                 ^util-macros.19.1%gcc.3.0 arch=linux-centos7-x86_64
                             ^libxfont.5.2%gcc.3.0 arch=linux-centos7-x86_64
                                 ^freetype.9.1%gcc.3.0 patches=08466355e8649235ff01f13b3e56bbd551c7cfb2ca97903cc11575c163ea32a3 arch=linux-centos7-x86_64
                                     ^libpng.6.34%gcc.3.0 arch=linux-centos7-x86_64
                                         ^zlib.2.11%gcc.3.0+optimize+pic+shared arch=linux-centos7-x86_64
                                 ^libfontenc.1.3%gcc.3.0 arch=linux-centos7-x86_64
                                     ^xproto.0.31%gcc.3.0 arch=linux-centos7-x86_64
                                 ^xtrans.3.5%gcc.3.0 arch=linux-centos7-x86_64
                         ^mkfontdir.0.7%gcc.3.0 arch=linux-centos7-x86_64
                             ^mkfontscale.1.2%gcc.3.0 arch=linux-centos7-x86_64
                     ^gperf.0.4%gcc.3.0 arch=linux-centos7-x86_64
                     ^libxml2.9.9%gcc.3.0~python arch=linux-centos7-x86_64
                         ^libiconv.15%gcc.3.0 arch=linux-centos7-x86_64
                         ^xz.2.4%gcc.3.0 arch=linux-centos7-x86_64
                 ^glib.56.3%gcc.3.0~libmount patches=c325997b72a205ad1638bb3e3ba0e5b73e3d32ce63b2d0d3282f3e3a2ff4663c tracing=none arch=linux-centos7-x86_64
                     ^gettext.19.8.1%gcc.3.0+bzip2+curses+git~libunistring+libxml2 patches=9acdb4e73f67c241b5ef32505c9ddf7cf6884ca8ea661692f21dca28483b04b8 +tar+xz arch=linux-centos7-x86_64
                         ^tar.31%gcc.3.0 arch=linux-centos7-x86_64
                     ^libffi.2.1%gcc.3.0 arch=linux-centos7-x86_64
                     ^pcre.42%gcc.3.0~jit+multibyte+utf arch=linux-centos7-x86_64
                     ^python.7.16%gcc.3.0+bz2+ctypes+dbm+lzma~nis~optimizations+pic+pyexpat+pythoncmd+readline+shared+sqlite3+ssl~tix~tkinter+ucs4~uuid+zlib arch=linux-centos7-x86_64
                         ^expat.2.5%gcc.3.0+libbsd arch=linux-centos7-x86_64
                             ^libbsd.9.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^openssl.1.1c%gcc.3.0+systemcerts arch=linux-centos7-x86_64
                         ^sqlite.28.0%gcc.3.0+fts~functions arch=linux-centos7-x86_64
                 ^pixman.38.0%gcc.3.0 arch=linux-centos7-x86_64
             ^curl.63.0%gcc.3.0~darwinssl~gssapi~libssh~libssh2~nghttp2 arch=linux-centos7-x86_64
             ^icu4c.1%gcc.3.0 cxxstd=11 arch=linux-centos7-x86_64
             ^libjpeg-turbo.0.2%gcc.3.0 arch=linux-centos7-x86_64
                 ^cmake.15.1%gcc.3.0~doc+ncurses+openssl+ownlibs~qt arch=linux-centos7-x86_64
                 ^nasm.14.02%gcc.3.0 arch=linux-centos7-x86_64
             ^libtiff.0.10%gcc.3.0 arch=linux-centos7-x86_64
             ^openjdk.0.2%gcc.3.0 arch=linux-centos7-x86_64
             ^pango.41.0%gcc.3.0~X arch=linux-centos7-x86_64
                 ^gobject-introspection.56.1%gcc.3.0 patches=6f90bb267efa043ed70b900b4b8e2faf9e8133afae311893b01060356ea81bba arch=linux-centos7-x86_64
                     ^bison.0.5%gcc.3.0 arch=linux-centos7-x86_64
                         ^help2man.47.8%gcc.3.0 arch=linux-centos7-x86_64
                     ^flex.6.4%gcc.3.0+lex patches=09c22e5c6fef327d3e48eb23f0d610dcd3a35ab9207f12e0f875701c677978d3 arch=linux-centos7-x86_64
                         ^libtool.4.6%gcc.3.0 arch=linux-centos7-x86_64
                 ^harfbuzz.3.1%gcc.3.0 arch=linux-centos7-x86_64
             ^tcl.6.8%gcc.3.0 arch=linux-centos7-x86_64
    
     ###################
    
     $spack spec r-edger ^r@:3.5.0
     Input spec
     --------------------------------
     r-edger
         ^r.5.0
    
     Concretized
     --------------------------------
     r-edger.22.3%gcc.3.0 arch=linux-centos7-x86_64
         ^r.5.0%gcc.3.0~X~external-lapack~memory_profiling~rmath arch=linux-centos7-x86_64
             ^bzip2.0.8%gcc.3.0+shared arch=linux-centos7-x86_64
                 ^diffutils.7%gcc.3.0 arch=linux-centos7-x86_64
             ^cairo.16.0%gcc.3.0~X+pdf arch=linux-centos7-x86_64
                 ^fontconfig.12.3%gcc.3.0 arch=linux-centos7-x86_64
                     ^font-util.3.1%gcc.3.0 fonts=encodings,font-adobe-100dpi,font-adobe-75dpi,font-adobe-utopia-100dpi,font-adobe-utopia-75dpi,font-adobe-utopia-type1,font-alias,font-arabic-misc,font-bh-100dpi,font-bh-75dpi,font-bh-lucidatypewriter-100dpi,font-bh-lucidatypewriter-75dpi,font-bh-ttf,font-bh-type1,font-bitstream-100dpi,font-bitstream-75dpi,font-bitstream-speedo,font-bitstream-type1,font-cronyx-cyrillic,font-cursor-misc,font-daewoo-misc,font-dec-misc,font-ibm-type1,font-isas-misc,font-jis-misc,font-micro-misc,font-misc-cyrillic,font-misc-ethiopic,font-misc-meltho,font-misc-misc,font-mutt-misc,font-schumacher-misc,font-screen-cyrillic,font-sun-misc,font-winitzki-cyrillic,font-xfree86-type1 arch=linux-centos7-x86_64
                         ^autoconf.69%gcc.3.0 arch=linux-centos7-x86_64
                             ^m4.4.18%gcc.3.0 patches=3877ab548f88597ab2327a2230ee048d2d07ace1062efe81fc92e91b7f39cd00,fc9b61654a3ba1a8d6cd78ce087e7c96366c290bc8d2c299f09828d793b853c8 +sigsegv arch=linux-centos7-x86_64
                                 ^libsigsegv.11%gcc.3.0 arch=linux-centos7-x86_64
                             ^perl.26.2%gcc.3.0+cpanm patches=0eac10ed90aeb0459ad8851f88081d439a4e41978e586ec743069e8b059370ac +shared+threads arch=linux-centos7-x86_64
                                 ^gdbm.18.1%gcc.3.0 arch=linux-centos7-x86_64
                                     ^readline.0%gcc.3.0 arch=linux-centos7-x86_64
                                         ^ncurses.1%gcc.3.0~symlinks~termlib arch=linux-centos7-x86_64
                                             ^pkgconf.6.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^automake.16.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^bdftopcf.0.5%gcc.3.0 arch=linux-centos7-x86_64
                             ^fontsproto.1.3%gcc.3.0 arch=linux-centos7-x86_64
                                 ^util-macros.19.1%gcc.3.0 arch=linux-centos7-x86_64
                             ^libxfont.5.2%gcc.3.0 arch=linux-centos7-x86_64
                                 ^freetype.9.1%gcc.3.0 patches=08466355e8649235ff01f13b3e56bbd551c7cfb2ca97903cc11575c163ea32a3 arch=linux-centos7-x86_64
                                     ^libpng.6.34%gcc.3.0 arch=linux-centos7-x86_64
                                         ^zlib.2.11%gcc.3.0+optimize+pic+shared arch=linux-centos7-x86_64
                                 ^libfontenc.1.3%gcc.3.0 arch=linux-centos7-x86_64
                                     ^xproto.0.31%gcc.3.0 arch=linux-centos7-x86_64
                                 ^xtrans.3.5%gcc.3.0 arch=linux-centos7-x86_64
                         ^mkfontdir.0.7%gcc.3.0 arch=linux-centos7-x86_64
                             ^mkfontscale.1.2%gcc.3.0 arch=linux-centos7-x86_64
                     ^gperf.0.4%gcc.3.0 arch=linux-centos7-x86_64
                     ^libxml2.9.9%gcc.3.0~python arch=linux-centos7-x86_64
                         ^libiconv.15%gcc.3.0 arch=linux-centos7-x86_64
                         ^xz.2.4%gcc.3.0 arch=linux-centos7-x86_64
                 ^glib.56.3%gcc.3.0~libmount patches=c325997b72a205ad1638bb3e3ba0e5b73e3d32ce63b2d0d3282f3e3a2ff4663c tracing=none arch=linux-centos7-x86_64
                     ^gettext.19.8.1%gcc.3.0+bzip2+curses+git~libunistring+libxml2 patches=9acdb4e73f67c241b5ef32505c9ddf7cf6884ca8ea661692f21dca28483b04b8 +tar+xz arch=linux-centos7-x86_64
                         ^tar.31%gcc.3.0 arch=linux-centos7-x86_64
                     ^libffi.2.1%gcc.3.0 arch=linux-centos7-x86_64
                     ^pcre.42%gcc.3.0~jit+multibyte+utf arch=linux-centos7-x86_64
                     ^python.7.16%gcc.3.0+bz2+ctypes+dbm+lzma~nis~optimizations+pic+pyexpat+pythoncmd+readline+shared+sqlite3+ssl~tix~tkinter+ucs4~uuid+zlib arch=linux-centos7-x86_64
                         ^expat.2.5%gcc.3.0+libbsd arch=linux-centos7-x86_64
                             ^libbsd.9.1%gcc.3.0 arch=linux-centos7-x86_64
                         ^openssl.1.1c%gcc.3.0+systemcerts arch=linux-centos7-x86_64
                         ^sqlite.28.0%gcc.3.0+fts~functions arch=linux-centos7-x86_64
                 ^pixman.38.0%gcc.3.0 arch=linux-centos7-x86_64
             ^curl.63.0%gcc.3.0~darwinssl~gssapi~libssh~libssh2~nghttp2 arch=linux-centos7-x86_64
             ^icu4c.1%gcc.3.0 cxxstd=11 arch=linux-centos7-x86_64
             ^libjpeg-turbo.0.2%gcc.3.0 arch=linux-centos7-x86_64
                 ^cmake.15.1%gcc.3.0~doc+ncurses+openssl+ownlibs~qt arch=linux-centos7-x86_64
                 ^nasm.14.02%gcc.3.0 arch=linux-centos7-x86_64
             ^libtiff.0.10%gcc.3.0 arch=linux-centos7-x86_64
             ^openjdk.0.2%gcc.3.0 arch=linux-centos7-x86_64
             ^pango.41.0%gcc.3.0~X arch=linux-centos7-x86_64
                 ^gobject-introspection.56.1%gcc.3.0 patches=6f90bb267efa043ed70b900b4b8e2faf9e8133afae311893b01060356ea81bba arch=linux-centos7-x86_64
                     ^bison.0.5%gcc.3.0 arch=linux-centos7-x86_64
                         ^help2man.47.8%gcc.3.0 arch=linux-centos7-x86_64
                     ^flex.6.4%gcc.3.0+lex patches=09c22e5c6fef327d3e48eb23f0d610dcd3a35ab9207f12e0f875701c677978d3 arch=linux-centos7-x86_64
                         ^libtool.4.6%gcc.3.0 arch=linux-centos7-x86_64
                 ^harfbuzz.3.1%gcc.3.0 arch=linux-centos7-x86_64
             ^tcl.6.8%gcc.3.0 arch=linux-centos7-x86_64
         ^r-limma.36.2%gcc.3.0 arch=linux-centos7-x86_64
         ^r-locfit.5-9.1%gcc.3.0 arch=linux-centos7-x86_64
             ^r-lattice.20-35%gcc.3.0 arch=linux-centos7-x86_64
         ^r-rcpp.0.0%gcc.3.0 arch=linux-centos7-x86_64
    
    点赞 评论 复制链接分享
  • weixin_39914975 weixin_39914975 5月前

    I‘ve solved the first problem the last few days.Version conflicts can be achieved by lowering the version requirements of one of the software. $ spack install trinity.6.6 %gcc.4.0 ^r@:3.5.3 ^r-edger.22.3 ^r-biocgenerics.26.0 ^py-numpy.16.4

    The above command make trinity.6.6 compile. Anyway,compiling a software requires different versions of software support is a very troublesome problem.

    点赞 评论 复制链接分享

相关推荐