ubuntu下rvm安装ruby报错

错误如下,在线等,谢谢
rvm install ruby-2.2
Searching for binary rubies, this might take some time.
No binary rubies available for: ubuntu/14.04/x86_64/ruby-2.2.1.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for ubuntu.
Installing requirements for ubuntu.
mkdir: 无法创建目录"/usr/local/rvm/log/1443528316_ruby-2.2.1": 权限不够
tee: /usr/local/rvm/log/1443528316_ruby-2.2.1/update_system.log: 没有那个文件或目录
Updating systemfangshuxian password required for 'apt-get --quiet --yes update':
............
Error running 'requirements_debian_update_system ruby-2.2.1',
showing last 15 lines of /usr/local/rvm/log/1443528316_ruby-2.2.1/update_system.log
tail: 无法打开"/usr/local/rvm/log/1443528316_ruby-2.2.1/update_system.log" 读取数据: 没有那个文件或目录
Requirements installation failed with status: 1.

1个回答

mkdir: 无法创建目录"/usr/local/rvm/log/1443528316_ruby-2.2.1": 权限不够

权限的问题,先sudo提权。

fang358229166
fang358229166 感谢大神!
接近 5 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问