Hibernate4的配置文件DTD信息可不可以使用3.0的版本?

小弟最近搭建了一个Struts2+Hibernate4+Spring4的开发环境,在搭建过程中由于没注意Hibernate4的配置文件是用了3.0版本的DTD信息,如下:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE hibernate-mapping PUBLIC
"-//Hibernate/Hibernate Mapping DTD 3.0//EN"
"http://hibernate.sourceforge.net/hibernate-mapping-3.0.dtd">
可是项目运行并没有报错,所以想请教一下这样到底是可不可以的?可能会带来什么样的后果?看网上一些人的配置好像也是这样,想问问最合理的应该是怎样?

2个回答

这个是关于Hibernate版本的问题吧,能用就行了!最合理是Hibernate选择较为稳定的版本!

u012561176
茕夜 回复conleyfree: Hibernate 3.x吧,最新的大部分都不怎么稳定,比如struts2的新版本就有些东西不能实现!
4 年多之前 回复
conleyfree
conleyfree 较为稳定的版本是?
4 年多之前 回复

这个要具体看下两者的区别的

conleyfree
conleyfree 所以不是很清楚会不会带来什么意想不到的后果?
4 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问